Unable to click on 'Don't Update' on Excel Pop Up

image

Hello,

I’m trying to handle this pop up by clicking on the ‘Don’t Update’ button. I was previously using the 2018 version and had recently upgraded to 2021.10.3. In the older version, I could achieve this by simply using a parallel activity, but this does not seem to work here. Given below is a screenshot of the flow I had tried to resolve this issue.

I have already gone through a few other posts related to the same issue and I tried out the solutions suggested there, but so far am unsuccessful.

Hi @Aaron_George

After opening excel Try Using Element Exists Indicating the PopUp

If the Pop Up Exists Then Click the DontUpdate button

And Perform the actions after that!

Regards

Hi @pravin_calvin

I tried that out as well. But the issue I’m facing in that case is that, the bot does not execute anything within the Application Scope. It just halts it’s execution at that point.

For example, the log message ‘Before Read’ is not being logged.

Hi @Aaron_George ,

If your excel file is static, means that you are using the same excel file each time, then I think that one solution would be to configure your excel file in order to not ask you that message

To suppress the message and to automatically update the links when you open a workbook in Excel, follow these steps:

1. Select File > Options > Advanced.
2. Under General, click to clear the Ask to update automatic links check box.

Source: https://docs.microsoft.com/en-us/office/troubleshoot/excel/control-startup-message#automatic-update-and-no-message

Hope it helps!
Best regards,
Marius

Hi @Marius_Puscasu

The excel file I’m using is not static, it’s being replaced on a daily basis.
Sorry, I missed to mention that.

you need to use parallel with "isolated property in order to open a separate thread to handle the popup, otherwise it wont work, because that popup is like a message box in uipath - it pauses execution until you press it manually

use my snippet

steps

  1. open handle popup in process -main xaml
  2. drag your sequence here
  3. open this sequence
  4. update this selector to that of your “Dont update links” button
2 Likes

Hi @jack.chan

This is great. It worked perfectly. Thanks a lot.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.