Unable to access Shared Mailbox through Outlook or O365

I’m using Studio 2021.4.4 and unable to access Shared Mailbox using Outlook or O365.

2021.4 release notes show this is a new feature.

MS Office syntax indicates \sharedMailbox\Folder is proper syntax.

Error is:
Get Mail transaction list: Value cannot be null.
Parameter name: folderPath

Access no problem using Outlook client and same credential that developer/robot uses. Powershell commands also successful accessing shared mailbox.

Robot Outlook mailbox has owner permissions on Shared Mailbox and Registered application has Mail.Readwrite.Shared permissions.

I’d love to hear from anyone who has made this work!

Hi @bsenter,

I see you are using below office365 package.
Which activity and steps are you using to achieve this?


Also, have you tried with removing first slash:



My requirement is O365, but I’ve tested and failed using thick client. Package versions with reported issue are
UiPath.MicrosoftOffice365.Activities v1.9.0
UiPath.Mail.Activities v1.8.6, but seeing update available to v1.10.5 I applied latest.

The syntax I reported originally is incorrect. MS Doc indicates \\sharedMailbox\Folder.
I’ve tried (to no avail):

Do you have a working model of O365 and Shared Mailbox that works?

This is resolved. Correction and Resolution below.

Correction: Problem was accessing Group Mailbox (not Shared Mailbox) using O365 Activity.

Resolution: I needed to use the Group Mailbox account in the Get Mail Activity (including domain: GroupMailbox@mymail.com).

While Outlook has the Group Mailbox visible, in O365 that really isn’t what it is doing. It needs the Group Mailbox in the Account parameter.

Syntax for folder path within the mailbox is folder\subfolder

Thank you @bsenter for sharing update.

Now that this issue is resolved, please mark solution so this topic can be closed.


This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.