Uipath unable to locate Power shell

Hello Team,

I am facing a strange issue with Uipath’s Invoke Power shell Activity . When i tried running it . I am getting an error on Win 10 64 bit machine as Windows PowerShell 1.0 is not installed ,which is required by Invoke Powershell Activity.
Exception type system.InvalidOperationException .

Any help would be much appreciated .

Thanks

Hi All,

I am also facing the same issue,

We have migrated a live project from version 2016.2 to 2018.4 and Invoke Power shell activity is throwing error.

Any help would be appreciated.

Thanks,
Madhura

add C:\windows\System32\WindowsPowerShell\v1.0\ to your PATH environment variable.

Hi !!!

I have added an environment variable for the same,

But still the error has not resolved.

Regards
Madhura

@Madhura is my account which was created when I was unable to reset password for my regular account. Please reply to @Madhuraj

Thanks
Madhura

@Madhuraj

  1. Can you share the error screenshot.

@Prashant_08

I cant share the screenshot due to firewall settings.

Thanks

I am having the same error. May I know how to add C:\windows\System32\WindowsPowerShell\v1.0\ to PATH environment variable.

Hello- Was anyone able to find a solution for this issue? Thanks

Approach 1
Windows Features -> Turn windows features on or off -> Windows powershell 2.0 (Enable)

image

image.png1012×1030 194 KB

  1. Enable the same.
  2. Perform a reboot of the server

verify

Approach 2:
Installation of powershell 2.0 in windows 10 has solved the issue.
Please find the link
(Download link may change in future)
https://www.microsoft.com/en-in/download/details.aspx?id=2560

Install the same

Reboot
verify

Approach 3:
install using PowerShell 1.0 Installation Package

Download the following from below link and try installing.
(Download link may change)

https://www.microsoft.com/en-us/download/details.aspx?id=23200

Install the same

Reboot the server
verify

1 Like

I have faced the same issue. I think this issue is from UiPath side. I have updated the UiPath.System.Activities package to 20.4.0, the issue get resolved.

Now for me, powershell is working fine.