UiPath Studio XAML file doesn't work in Server (all images are missing)

Hi Team,

Hope all is well with you.

I have a quick question on one issue which I am facing now :frowning:
I have done SAP automation in UiPath studio in my local system but when I am trying to copy and paste that XAML file in Server I am not able to see any images(recording sequence), below is the screenshot of error which I am seeing.

image

Looking forward for your response on this.

Regards,
Rahul

1 Like

i hope its because of the package version compatibility
ensure that the packages in your local machine uipath studio is also installed in this server
and all the package must be of same version
–for that go to design tab and in manage packages option install the packages we want or if its there already upgrade or downgrade the package version
–then it would work

Cheers @Rahulsinha

1 Like

Thanks for your response, yes i have downgraded the system as it was in the server, but still the same issue :frowning:

1 Like

buddy do you mean the packages were installed and downgraded or upgraded to exact version of packages in your local machine
better copy the whole project folder and paste in your server and try opening the xaml
so that the image from screenshot folder and the project.json file will help inn accessing the packages
but ensure that the activity packages are also copied and pasted from your local to server from this folder
C:\ProgramData\UiPath\Packages

kindly try this and let know for any queries or clarification @Rahulsinha
Cheers

1 Like

All images get stored in the .screenshots folder . You may have to copy this folder as well along with the .xaml file to be able to see the images.

Hope this helps.

1 Like

How to downgrade the version to 2019.4.4 from 2019.10.0 beta(its a community edition) ?

1 Like

How to downgrade the version to 2019.4.4 from 2019.10.0 beta(its a community edition) ?
Kindly advise

1 Like

Fine
downgrade is about the activity package and not the studio version buddy
–for that go to design tab and in manage packages option install the packages we want or if its there already upgrade or downgrade the package version
–then it would work

if the xaml file itself is not opening means remove the project.json file and try opening the xaaml

Cheers @Rahulsinha

1 Like

image :frowning:

1 Like

yah kindly remove the project.json file and open the xaml
Cheers @Rahulsinha

Yes buddy that I have done, and able to open the WF but it is unable to recognize the screenshot, getting the below error. :frowning:

Fine
in your local machine studio go to design tab and the get the packages used and its version
–and in your server machine go to same design tab and install those packages by searching them from OFFICIAL tab if those packages are missing or if its there ensure that the version is same, if not upgrade or downgrade the version of those packages
for example
with the highlighted are we can either upgrade or downgrade the version of the package

kindly try this and let know forr any queries or clarification
Cheers @Rahulsinha

I am not able to upgrade the version in Server

How to solve the below issue :frowning: