UiPath Studio - Record option is not recognizing any app (not highlighting the screen element) and giving a run-time error


#1

Hi All,
i am a newcomer here, installed UiPath Studio 18.4.1 version and tried hands-on to replicate from a tutorial. when i tried to do screen recording, it is not recognizing any app (not highlighting the screen element on mouse-over) and even when i force-fully open any application from run-command, it is not registering it properly. When saved and run, it is giving the below run-time error. i am operating on my personal laptop running Windows 10 (version 1709), so i dont think any admin privileges to be a reason. kindly advise.

18.4.1+Branch.master.Sha.bc66386dd8e2160b6d35f31d5ce934a5aa4cf4bd

Source: Open ‘explorer.exe’

Message: Selector not found

Exception Type: System.Runtime.InteropServices.COMException

An ExceptionDetail, likely created by IncludeExceptionDetailInFaults=true, whose value is:
System.Runtime.InteropServices.COMException: Selector not found
at UiPath.Core.Activities.ScopeActivity.EndExecute(NativeActivityContext context, IAsyncResult result)
at UiPath.Core.Activities.AsyncNativeActivity.BookmarkResumptionCallback(NativeActivityContext context, Bookmark bookmark, Object value)
at System.Activities.Runtime.BookmarkCallbackWrapper.Invoke(NativeActivityContext context, Bookmark bookmark, Object value)
at System.Activities.Runtime.BookmarkWorkItem.Execute(ActivityExecutor executor, BookmarkManager bookmarkManager)


#2

There might be some issues with the package UiPath.Core.Activities. Try reinstalling the same if it doesn’t work try downgrading the package by one version.


#3

Thank you for the immediate response. I tried re installing on 3 different laptops, but no use.
Can you please tell me how to downgrade the uipath studio installed version.


#4

Since You are using 2018.4 you may not see UiPath.Core.Activities.

Can you try downgrading the package as shown below ?


#5

hi,

sorry for a delayed response. i tried as suggested by you by downgrading. but, still no use.
i am providing the screen capture through the below link. kindly check and advise.

regards
sriram


#6

hi all,
i tried to install on an old machine running on windows 7 and it worked like a breeze. i guess there seems to be a compatibility problem with windows 10.
can anyone advise on this please.