Level 1 - Lesson 2 - Practice 1 selector localization issue

I just started learning UiPath, and at Level 1 - lesson 2 - Practice 1, I tried to open Notepad.exe with UiPath.Core.Actvities.OpenApplication, but the selector was not generated. I downloaded the “Lesson 2 Practice 1 - Simple Math Question - Answers” project and checked the same selector. It also indicated an (invalid selector) error. (see picture)
image
If I let run the project, the notepad will open properly and then com up shortly the following error message, which clearly indicates the selector error.

“An ExceptionDetail, likely created by IncludeExceptionDetailInFaults=true, whose value is:
System.Runtime.InteropServices.COMException: Cannot find the UI element corresponding to this selector:
at UiPath.Core.Activities.ScopeActivity.EndExecute(NativeActivityContext context, IAsyncResult result)
at UiPath.Core.Activities.AsyncNativeActivity.BookmarkResumptionCallback(NativeActivityContext context, Bookmark bookmark, Object value)
at System.Activities.Runtime.BookmarkCallbackWrapper.Invoke(NativeActivityContext context, Bookmark bookmark, Object value)
at System.Activities.Runtime.BookmarkWorkItem.Execute(ActivityExecutor executor, BookmarkManager bookmarkManager)”

I was looking for “invalid selector” on the forum, but I couldn’t find a solution or I didn’t understand it.
Please help me, what am I doing wrong? If it stays so, I can’t continue learning.

Regards and thanks.

Windows 10, UiPath 2019.4.2, .NET Framework 4.8.

1 Like

Buddy @mmatt
Welcome to UiPath community buddy

Well kindly pass this file name as input to your open application activity property
"C:\WINDOWS\system32\notepad.exe"

The reason why its showing as invalid is the notepad window is not active buddy, thats why but its not a big deal your selector looks perfect, you are going good actually
notepad.zip (3.3 KB)

Here is your xaml for reference buddy, hope this would help you identify the issue
But kindly try once with your studio, as you are doing good already. @mmatt

Cheers

were you able to proceed buddy, no worries we can tweak a bit on this and lets sort this out
@mmatt
Cheers

Hi Buddy @Palaniyappan,

thanks for your very quick response. I’ve tried your notepad.xaml, but the thing failed after opening notepad again.

BUT, I started thinking, and suddenly I noticed what was under my nose all the time:
We use a localized Hungarian Windows where notepad appears instead of English title ‘Untitled - Notepad’ with a Hungarian title: ‘Névtelen - Jegyzettömb’.
I corrected all selectors to and the peace has broken out. :slight_smile:

Thanks for your help. Perhaps this experience may be useful for other folks using localized Windows.

Best regards,
mmatt

Amazing buddy… @mmatt
It changes with application and system language… buddy @mmatt
If so, Kindly close this topic with right comment marked as solution that could help others looking for ideas under topic buddy

Cheers…
Keep going

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.