Uipath Studio - Error "" - *Object reference not set to an instance* - With just one activity in it

I have a query I had a workflow which was working fine. Now suddenly it is giving the below error

Object reference not set to an instance

I checked if there is any empty variable, there is nothing
I commented the entire workflow and gave just one write line even that gives me same error. Please help.
Looking in to this from a while now. Hence requesting help.

Thanks
Vinod

@vinodcrimson run it in debug mode once.

Are there any arguments that are empty?

Debug will identify the missing object.

@venkatmalla6 - I tried that too still i get the same error. It does not proceed.

@vinodcrimson if possible can you post the screenshot of your flow or you can share your xaml file.

1 Like

@TimK - No i have not used any arguments.

PFB the project.json file, i have doubt if this has a problem, because the dependencies looks like below

Please find below the project.json file

{
“name”: “JIRA_RPA_Original”,
“description”: “JIRA_RPA_Original”,
“main”: “Main.xaml”,
“dependencies”: {},
“excludedData”: [
“Private:*”,
password
],
“toolVersion”: “18.2”,
“projectVersion”: “1.0.7132.23108”,
“packOptions”: {},
“runtimeOptions”: {}
}

Are you able to post the workflow (variables view also)

@vinodcrimson there are no dependencies present in this json file,
it should contain like this dependencies": {
“UiPath.UIAutomation.Activities”: “[19.3.0]”,
“UiPath.System.Activities”: “[19.3.0]”,
“UiPath.Excel.Activities”: “[2.5.2]”,
“UiPath.Mail.Activities”: “[1.3.0]”
},like the way the dependencies should show in json file.

@TimK and @venkatmalla6 - Issue is fixed - It was a datatype problem hence one variable was not getting assigned to a value. I tried hardcoding the value. This fixed the issue.

@venkatmalla6 - I understand that the project.json should be that way, but it is still the same. Don’t know how to fix if that’s an error.

Thanks alot to both for such a quick help.
Thanks
Vinod

1 Like

Usually ‘Object reference not set to an instance’ error occurs when you are trying to access a variable / argument that doesn’t hold a value or hasnt been declared correctly.

Glad you resolved it :slight_smile:

1 Like