Object reference error - unable to do anything

Hello everyone. I just reinstalled UiPath Studio. I had some projects finished before but after the reinstallation it happened that I am unable to execute anything without the “Object reference not set to an instance of an object.” sign showing up.

It happened the same to a colleage.

I tried creating a new project from zero, I’m just using a single variable that contains one string and a “message box” activity. That is the project all about.

I also got the log:

12:02:03.7668 => [ERROR] [UiPath.Studio] [1] Error: UiPath.WorkflowProcessor.Common.Exceptions.UiPathLocalizedException: Object reference not set to an instance of an object.
at UiPath.WorkflowProcessor.Common.Preprocessing.WorkflowDocumentPreprocessor.GetDependencyTree(LoggingScope scope, String xamlFilePath, IDictionary2 codeSourceFiles) at UiPath.Studio.ProjectCompiler.Services.ProjectCompilerService.<>c__DisplayClass9_0.<CalculateCompilationDependencies>b__1(String wf) at System.Linq.Enumerable.SelectEnumerableIterator2.MoveNext()
at System.Linq.Enumerable.SelectManySingleSelectorIterator2.MoveNext() at System.Linq.Enumerable.DistinctIterator1.MoveNext()
at System.Linq.Enumerable.WhereEnumerableIterator1.ToArray() at UiPath.Studio.Plugin.Workflow.Execution.Services.ExecutionCompilationService.CompileInternal(Boolean calculateWorkflowDependencies) at UiPath.Studio.Plugin.Workflow.Execution.Services.ExecutionCompilationService.Compile(String entryWorkflow) at UiPath.Studio.Plugin.Workflow.Execution.Services.ExecutionStartConfigurator.ConfigureAsync(Boolean firstExecutionInBatch, Boolean lastExecutionInBatch, IEnumerable1 batchedDocuments, String entryWorkflow)
at UiPath.Studio.Plugin.Workflow.Execution.Services.WorkflowExecutor.StartExecution(ExecutionConfig config)
at UiPath.Studio.Shell.Execution.Services.ExecutionManagerBaseService.TryStartExecution(ExecutionConfig executionConfig, Boolean validate)
at UiPath.Studio.Shell.Execution.Services.ExecutionManagerService.<>c__DisplayClass27_0.<g__StartExecutionAsync|1>d.MoveNext()
— End of stack trace from previous location —
at UiPath.Studio.Shell.Execution.Services.ExecutionManagerService.ProcessExecutionCommand(ExecutionCommand command, Object item, ExecutionParameters executionParameters)
at UiPath.Studio.Shell.ViewModels.DebugTabViewModel.ExecuteRunProjectAsync()
at UiPath.Studio.App.Desktop.MVVM.Commands.TaskCommand`3.Execute(TExecuteParameter parameter, Boolean ignoreCanExecuteCheck)
at System.Threading.Tasks.Task.<>c.b__128_0(Object state)
at System.Windows.Threading.ExceptionWrapper.InternalRealCall(Delegate callback, Object args, Int32 numArgs)
at System.Windows.Threading.ExceptionWrapper.TryCatchWhen(Object source, Delegate callback, Object args, Int32 numArgs, Delegate catchHandler), HResult -2146233088

We are also unable to use our old projects, the same error appears.

Any hint on what it could be?

Thanks in advance

Hello, try deleting variable palabra from Message Box, then start reentering it and select from intellisense.


Hi michael, thanks for the reply.

I tried your solution but it didn’t work.

This small new project I created it was just for testing a very simple sequence. All my previous projects that used to work have the same outcome. Everything I do in UiPath now returns that error.

Sorry to hear, try deleting the variable, then in Message Box Control K - create variable again, then assign it “hola”…see what happens?


Hi @andres.enriquez,

Welcome to community.

I believe you are getting this error because the variable is coming in empty, but we can see from your post that it’s not empty. Could it be that your project is starting from Main when you click ‘Run’? Are you sure you’re only running this page by clicking ‘Run File’


1 Like

Hi, look:

I just type the text inside de message box but nothing happens, I guess it isn’t anything related to variables. Before the reinstallation everything was working well.

Hi, Muhammed, thanks for the reply.
Look, I selected the file I am using as the current one.

I don’t know I just created this new project from zero but nothing seems to works, using variables or not.

Hi @andres.enriquez ,

Does it give the same error if you have an entirely new project created as well?

Could you let us know what were the changes observed from the Previous Project (Before Re-installing Studio) to the Current Version ? Was the Studio Upgraded or just the re-install of the same version ?

Was there a change in the Compatibility from Windows-Legacy to Windows ?

Exactly, same error.

I can tell you what it changed for me and my colleage. Our free trial for the UiPath Studio with Enterprise license expired (I understand that after it expires the current version becomes the “community”), we reinstalled it, we used the same file to install it. The difference between his installation and mine is that he could install the community version, in my case it installed automatically the UiPath Studio version, it still says it is Enterprise license while in my UiPath account it says: " License expired! We’re in the process of downgrading your Organization to the Community plan. Contact UiPath sales to renew your license and prevent interruption of service. Learn more"
We were intersted in using the community version from the beggining. In any case, our Enterprise free trial licenses expired. But still we are not allow to use any activities, even in brand new projects, we reinstalled it many times, same outcome.