UiPath.Python.Activities Scope problem

I’m having problems executing UiPath Python Scope Only.
The activity takes to much time in doing nothing.
Maybe I have something wrong in the configuration.
I’ll share it to you:

In the properties you could see I have Python 3.9

The problem is that I have other activities inside the Scope. But the robot is not getting from the scope to the first one which is load script.



Did you try changing the python package from manage pckages and check ?

Alternately instead of auto can you select the version

And I hope you have only one version of python installed


I’ve changed it from 1.6 to 1.4 and now I get this message:


Do you have .net 5.0 installed? If not please do


I’ve Installed the .NET version asked, and now I have this:



Source: Python Scope

Message: Error initializing Python engine

Exception Type: System.InvalidOperationException

System.InvalidOperationException: Error initializing Python engine —> System.InvalidOperationException: Python instantiation exception
Python Invoker program exception:
Exception has been thrown by the target of an invocation.
at UiPath.Shared.Service.PythonResponse.ThrowExceptionIfNeeded()
at UiPath.Python.Service.PythonProxy.Initialize(String path, Version version, String workingFolder)
at UiPath.Python.Impl.OutOfProcessEngine.Initialize(String workingFolder, CancellationToken ct, Double timeout)
at UiPath.Python.Activities.PythonScope.ExecuteAsync(NativeActivityContext context, CancellationToken cancellationToken)
— End of inner exception stack trace —
at UiPath.Shared.Activities.AsyncTaskNativeImplementation.BookmarkResumptionCallback(NativeActivityContext context, Object value)
at UiPath.Shared.Activities.AsyncTaskNativeActivity.BookmarkResumptionCallback(NativeActivityContext context, Bookmark bookmark, Object value)
at System.Activities.Runtime.BookmarkCallbackWrapper.Invoke(NativeActivityContext context, Bookmark bookmark, Object value)
at System.Activities.Runtime.BookmarkWorkItem.Execute(ActivityExecutor executor, BookmarkManager bookmarkManager)


Please increase the timeout please…1 might be pretty less


I think the problem is before everything, it occurs 3 secs after starting the execution. Right now I put 60. I understand it means 60 seconds?


  1. Not sure why you have double slashes please remove them
  2. Try selecting the version
  3. Is the installer 32 bit? If mot change to x64 from x86

Library and the python locations look proper.Hope you got the proper paths there



I’ve made the changes and start the execution but it gets stuck here:
Now Is not showing errors but is not ending the scope.

It looks like a problem with the .net runtime. I’ll reinstall to see if it works:


Could you try increasing the timeout as well.

Ok I got it.

If your Scope gets stuck and doesn’t end. First verify the systen event logs in Windows logs\applications you should find an error like mine:

In the same error explain that you need to install a missing framework and it gives you the link to install:

And that’s it, problem solved


This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.