UiPath performance has dropped Drastically

We recently switched over our entire Project from Windows-Legacy to Windows. Since then, the overall performance of UiPath has reduced significantly. We thought that the computer’s memory is inadequate and upgraded it to 32GB RAM (from earlier 16GB RAM).

Nevertheless the performance remains the same.

When I run my project for the first time after bootup, the Project Validation takes hours to complete (sometimes failing stating that Execution stopped due to Insufficient memory, in spite of having 32GB ram in the computer all to itself), also consuming almost of all the resources.

One noticeable difference is that the same project run very smoothly and is very fast over the Windows-Legacy for the same system configuration (same case when system RAM was 16GB).

Since we’d like to stick to the windows version for our project hereon, what can be done about this performance drop.

P.S: My current version of UiPath studio is 2022.12 (beta release from Dec end 2022).
You can also refer to the image attached to how the memory is getting all used up (during Project Validation).

Try to extract this Studio folder somewhere on your system. WeTransfer - Send Large Files & Share Photos Online - Up to 2GB Free

Then, open UiPath.Studio.exe, recompile all the libraries, project → save the project, and try to open it in the old installed Studio version.

Let us know if you see some RAM consumption performance.

In the next Studio releases, we will stick to solving multiple Studio performance issues.

Hi @marian.platonov
Thanks for your response.
Few doubts here.

  1. Since we’re using community edition, is there any way where we can downgrade UiPath to one of it’s previous versions and use/test out the following case. Because, the auto-updates have upgraded UiPath to the latest version. Would like to know the workaround if it’s possible.
  2. You mentioned that in the future Studio releases, the performance issues would be solved. Are these performance issues known currently?

Hi @marian.platonov
As per your instructions, I’ve tried to recompile the project. But the problem is the compilation itself is taking a lot of time and has a low success rate(i.e., it keeps failing midway stating that there is insufficient memory to execute the files).
This compilation also happens every time UiPath is opened afresh, which was not the case in Windows-legacy mode.
Coming to the general performance, it does not seem to be affected at all. Just the normal user experiences such as Placing an activity, editing the activity or scrolling through the workflow is sluggish, which is not the case when we try to use Windows-Legacy mode.

Raise a ticket with the Technical Support team to analyze your performance issues.

Hi @Peeyush_Yadav1 ,

Did you ever resolve this issue? I am getting the same issue with a file I’m running. RAM piles up ridiculously fast in studio, but execution isn’t an issue at all. Not sure what’s going on