UiPath Orchestrator APIs not working since Cloud Platform Release

Hi,

Last week I have created an account on cloud and I was able to connect using /api/Account/Authenticate from remote application. Today I just noticed the same application is getting an error and the error message is:
“We have updated our authentication stack. Please use the authentication method supported via UiPath Cloud Platform.”

Has anything changed in the last week? Well, when I access the URL, I am not seeing even Tenant name but it is showing Login with Google, Microsoft, LinkedIn. Can I just log in with Tenant name, username, and password as before? How can I log in by REST?

Thanks,

@kensho76

Yes login authentication was changed now and no need to enter Tenant name to login. We have to login through Google, Microsoft or LinkedIn and then enter credentials to login into it.

Hi,

Thanks for your response. Can’t we do the old way?

In the past I was passing below parameters in JSON body. From browser you may be able to use Google, Microsoft, or LinkedIn but what should I pass from REST request? I checked online document but it did not say about new specifications. Could you point to the latest one on Authenticate API?

{
“tenancyName”: “Default”,
“usernameOrEmailAddress”: “admin”,
“password”: “xyz”
}

Thanks,

Yes you can, use the forgot password link using your old email if not tied to one of the auth services.

Once reset, you’ll be able to access your account again.

@kensho76

I don’t know about new authentication. In Academy, there is new course like Uipath 2019.4 updates. Just go through that see once is there any update on that.

@loginerror @ovi

Is there any new Authenticate API for this ? Could you please help him.

I don’t understand. I have reset my password but afterward I access the cloud URL, but still it shows Google, Microsoft, and LinkedIn. I want to log in by old method which is entry of Tenant name, username, and password.

Thanks,

You should be presented with four options

  1. Google
  2. Microsoft
  3. LinkedIn
  4. Email

2 Likes

Hi @twhitehead,

Not sure why, but the email - password combo doesn’t log me in.

1 Like

Can you login with your username and password? which is the 4th option in the sign in page.
Then if you want to go to a specific tenant, you can go to the services tab and click on the tenant that you would like to access.

2 Likes

Reset your password through the Forgot password link if the email address is not tied to one of the three other auth providers. Information on this was included in the email to users when the platform was upgraded.

Social logins (Google, Microsoft, LinkedIn) are enabled for easier access. If your email account does not support it, you can use forgot password to continue with basic authentication.

Well, API fails. That’s why I need old authentication style. What I am trying to do is to log in through REST API, not through browser. UiPath Orchestrator returns a different message than wrong credentials:

This means I need to include different parameters than before I guess.

Thanks,

1 Like

My apologies, I had assumed it was tied to the password not resetting. I’ve just tried myself from the Swagger UI and it is producing the same.

Request URL

https://platform.uipath.com/<service>/<service>/api/Account/Authenticate

POST Body

{
  "usernameOrEmailAddress": "emailaddress@mail.xyz",
  "password": "********"
}

Response Body

{
  "message": "We have updated our authentication stack. Please use the authentication method supported via UiPath Cloud Platform.",
  "errorCode": 1415,
  "resourceIds": null
}

I don’t see a different in the Swagger documentation. Might be worthwhile to update your Topic description that is more accurate to your issue along with more details in your OP.

I’ll keep playing around with my account, if you have a Enterprise customer, might be worth while opening up a support ticket as well.

It is also the error produced when attempting to login by the original /account/login page

image

4 Likes

Well I am new to UiPath, and trying to build the very first PoC but how could such important specs change over the weekend, without any announce or documentation readiness…

Hope someone from product team would suggest as I am stuck.

Thanks,

Hi @twhitehead,

I too tried the exact same process, however I had no luck as well and got the same message

message: "We have updated our authentication stack. Please use the authentication method supported via UiPath Cloud Platform."

Let us know if you have any luck or breakthrough.

Meanwhile, I’ll be working on this as well.

Cheers,
Abdullah Nasir Jamal

Our team is working on a solution, I’ll make sure to share it as soon as possible.

8 Likes

Keep an eye on

or the announcement channel for further updates.

Their Welcome email indicates they’ll be migrating over the next few days.

We apologize for any service interruptions or errors you may experience in the following days while we continue migrating the entire platform.

2 Likes

I have been trying for 2 days and just tried again, Orchestrator is still down. Any updates?

Hi @syyad:

We are experiencing some outages and the team is working to fix them. We shall update once the issues are fixed. Thank you for the patience!

Do we have a resolution yet to this issue? Does anybody know the new API to authenticate to platform.uipath.com ?

Regards,
Aditya

@adityavikram

Not yet bro. They are working on that and soon we will get it.