UIPATH on Teamviewer

Hello guys.
I am trying to automate software by using Teamviewer. When I run it and watch it on the teamViwer screen, it runs perfectly, but when I close the TeamViwer screen, starts to give problem in the execution in several stages.
How do you solve this? The program is perfect, the only problem is if I stop watching it running on teamViwer.

Is the bot running on your computer or the remote computer? If it runs on your computer, you need to stay connected to TeamViewer.

If the bot is running in the remote computer, have you verified that the lock screen doesn’t activate when you disconnect TeamViewer?

image

2 Likes

It’s on remote computer. This TeamViwer option was actually enabled! I will test and see if it solved the problem.

It still doesn’t work. The only thing it did was click on update. After waiting for the delay to update it just had to press Save, but it gave an error. The delay is long enough.

@ptrobot

Sorry to hear that. Have you tested with Quick Assist instead of TeamViewer? (Just to verify if it’s TeamViewer or something else. I have read that sometimes it doesn’t respect the setting ever if you set it to Never lock the screen).

No, but I tested with Windows Remote desktop connection. Same problem.
I saw this Forum FAQ, I think it looks like my problem, but I couldn’t understand how it was solved

@Joao_Paulo_Araujo this is because when you exit, im assuming the RDP session is closing also.

https://support.smartbear.com/testcomplete/docs/testing-with/running/via-rdp/in-minimized-window.html

If that is the issue. This would solve your problem. Hope it helps :slight_smile:

The Sharmila’s thread is not related to your issue. She is running the bot from her computer. You can see that because her bot is accessing the Teamviewer window. The solution in that thread is basically to change the selector to something more general, i.e. changing the title from “TV 3.0” to “*”.

If you want to try Remote Desktop again, test to apply the registry fix as @seanrockvz13 mentioned but also disconnect using tscon. This ensure that the lock screen doesn’t activate. You can find the command line for tscon in the below link:

https://support.smartbear.com/testcomplete/docs/testing-with/running/via-rdp/keeping-computer-unlocked.html

This work only for Remote Desktop Windows?

Hi Joao, suggest you try this with your situation first. I have a feeling it will work.

Sorry everyone, I already found the error.
Every time that I closed remote access, this pop-up from TeamViwer appear on the remote computer screen and prevent the robot from worrking.
I disabled this auto message and is now working properly.image

2 Likes

Thanks for sharing Joao! New learning for all of us.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.