UiPath.MicrosoftTeams.Activities

I try to install the UiPath.MicrosoftTeams.Activities, but it fails, i also try to install older version of the package but it also fails.

I see from dependenciees that it refer to Graph.Beta 0.35.0. this was released long time ago, is there any plan to release a new updated package/activity with 4.15.0-preview

21.4.4+Branch.master.Sha.a8b5101efe02651274064093e9c7410fedfxxxxx

The following package(s) can not be installed:
UiPath.MicrosoftTeams.Activities 0.5.1

From the UiPath.Studio.log

17:57:20.6243 => [ERROR] [UiPath.Studio] [16] System.ArgumentNullException: Value cannot be null. (Parameter ‘o’)
at Newtonsoft.Json.Linq.JToken.FromObjectInternal(Object o, JsonSerializer jsonSerializer)
at TelemetryClient.Implementations.Flatteners.JsFlattener1.Flatten(IPropertyStore store, String key, T value) at System.Collections.Generic.List1.ForEach(Action1 action) at TelemetryClient.Contracts.Templates.OperationTemplate.New(TelemetryOperation operationTelemetry) at TelemetryClient.Contracts.TelemetryClientBuilder.TelemetryClient.StartOperation(TelemetryOperation telemetryOperation) at UiPath.Studio.Analytics.UiPathAnalyticsProvider.StartOperation(TelemetryOperation telemetryOperation), HResult -2147467261 17:57:20.8458 => [ERROR] [UiPath.Studio.App.Logging.OutputLogger] [58] NU1101: Unable to find package Microsoft.Graph.Beta. No packages exist with this id in source(s): C:\Users\xxxx\AppData\Local\UiPath\app-21.4.4\Packages, Connect, https://gallery.uipath.com/api/v2, https://raas-p-app.azurewebsites.net/nuget/v3/c9f874fe-a8dd-4c8a-a555-0e85ee9984ed/index.json, https://www.myget.org/F/workflow/, Local, Official 17:57:20.9773 => [ERROR] [UiPath.Studio.App.Logging.OutputLogger] [23] Cannot load assembly: C:\Users\xxxxx\.nuget\packages\uipath.microsoftteams.activities/0.5.1\lib/net461/UiPath.MicrosoftTeams.dll : System.IO.FileNotFoundException: Could not load file or assembly 'Microsoft.Graph.Beta, Version=0.35.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35' or one of its dependencies. The system cannot find the file specified. File name: 'Microsoft.Graph.Beta, Version=0.35.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35' at System.Reflection.RuntimeAssembly.GetExportedTypes(RuntimeAssembly assembly, ObjectHandleOnStack retTypes) at System.Reflection.RuntimeAssembly.GetExportedTypes() at UiPath.Studio.Plugin.Workflow.Services.AssemblyContainer.AddAssemblyInternal(Assembly assembly, String path) at UiPath.Studio.Plugin.Workflow.Services.AssemblyContainer.<>c__DisplayClass10_0.<ProcessAssemblies>b__0(Tuple2 range)

WRN: Assembly binding logging is turned OFF.
To enable assembly bind failure logging, set the registry value [HKLM\Software\Microsoft\Fusion!EnableLog] (DWORD) to 1.
Note: There is some performance penalty associated with assembly bind failure logging.
To turn this feature off, remove the registry value [HKLM\Software\Microsoft\Fusion!EnableLog].

You can download the activity from marketplace and use it.

Regarding download failure, can’t comment without checking whether other packages are getting installed?

Can you try installing this package in a new file just to make sure no other dependencies are affecting the installation.

Other packaged installs without any issues, i tried Office365, no issue there.

I believe these two package is one and the same. I also downloaded the nupkg package form the page and stored it locally and tried to install it from local resource, but same there as well.

I guess the package need a re-visit and fixed by UiPath since they are the maker of it (?).

Tried both local package and all so it would get from one of the other sources, non works.

I’ve used the package recently, it is working.

Are you on your office(work) laptop? It seems some policy is blocking the installation as I see a note in the error you mentioned:

Check with your IT team and get the confirmation if you can set that registry value to off.

Note: There is some performance penalty associated with assembly bind failure logging.
To turn this feature off, remove the registry value [HKLM\Software\Microsoft\Fusion!EnableLog].

1 Like

You are right, its on a work laptop, indeed. Oh man i was so into read everything else in the log up and down 10 times, that the last bit and clear part did not come to me. Ok, i will investigate this and thank you so much for pointing out this simple and obvious thing. I will definitely check it out.

1 Like

Happens with all!

You may post the resolution steps here, to have a Query + Solution pair on the forum, that will help others and also to close a post with a solution too.

After talking to one of my RPA colleagues at work, that came up with a solution to this issue (thank you colleagues) I did the following that allowed me to install the Teams Activity:

  1. Go to: NuGet Gallery | Microsoft.Graph.Beta 4.16.0-preview
  2. Click on the link on the right side to download the package
  3. On your own local computer, navigate to: C:\Users\xxxxxxAppData\Local\UiPath\app-21.4.4\Packages

PS: The correct path will be shown in the error package when one try to install it “NU1101: Unable to find package Microsoft.Graph.Beta. No packages exist with this id in source(s): C:\Users\xxxxxxx\AppData\Local\UiPath\app-21.4.4\Packages, Connect, https://gallery.uipath.com/api/v2, https://raas-p-app.azurewebsites.net/nuget/v3/c9f874fe-a8dd-4c8a-a555-0e85ee9984ed/index.json, https://www.myget.org/F/workflow/, Local, Official”

  1. Paste the package you downloaded in the previous step into your local package-folder.
  2. I restarted UiPath (maybe not needed, but I did)
  3. Went to “Manage Packages” in UiPath and re-installed the package.

Got a warning: “We have detected dependency downgrades. Do you want to fix them by upgrading to the higher version? Choose “No” to go back.”

“Package Dependency Conflict #1: Microsoft.Identity.Client
Type of conflict: Downgrade Dependency Conflict
The project refers package Microsoft.Identity.Client version which is lower than the one used in Microsoft.Graph.Core. We recommend upgrading to version 4.35.1.”

  1. Clicked yes, to get the latest items.

Result: It installed fine this time.

(In my own previous attempt i tried to put the Teams-activity manually in the Package-folder, but that did not work, my colleague suggested instead to take the Graph-package and put it in the same folder, so that worked.

Lesson learned: Read the error message properly, see what is missing and try to install that package in the package-folder. :slight_smile:

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.