UiPath is failing to identify Elements when i am using a shared screen in 2018.4.0

Hi all,

I created workflow and it is working fine. When i am trying to show a demo to one of colleague through Screen share using skype. When i am sharing my screen and trying the run the workflow it is failed to identify the Element.

Thanks in Advance :grinning:

Seems to be how the screen is being shared, and causing an overlay which UiPath cannot see past it.

I’ve used a few different meeting/sharing applications Cisco Jabber, WebEx, Skype for Business, Microsoft Teams and a few others. I’ve had troubles with Cisco Jabber, but the other three seem okay.

I haven’t specifically tried Skype (Consumer version), but haven’t had any troubles with Skype for Business sharing a desktop screen.

Hi @codemonkee ,

Thanks for the response. Even I have not seen any issue with Skype for Business.But when i used normal Skype i have seen the issue.


we too faced the same issue, when we tried to shre the screen via skype for business, the UI Automation failed to find the selectors.

To resolve this we had workaround like, we took a remote desktop connection from another systema and shred via skype hence it worked :stuck_out_tongue:


is there no other way to run my process in webex or in microsoft teams?

Does any one got the solution? I am facing the same issue both on MS Teams and Cisco Webex. Help me to resolve this issue.

Thanks in Advance

Hello, if you are using 2020.4 or above check the Picture-In-Picture feature