Uipath Automation not working properly when sharing screen

Hi All,

I have developed an automation which works well. But I try it to show somebody over teams or skype. It’s not able to find certain elements and perform operation on it. I have already tried with simulate click and send window messages. I have checked the selectors they are fine. Do anyone know what could be the issue and resolution of it.

from my experience, when you share the screen, the screen will act like a Citrix screen. so UiPath will failed for the selectors that you already captured. better do a screen recording to share.

2 Likes

Yes @ddrdushy1 is right. When screen is shared there is overlay layer which comes over the actual screen and hence the automation fails

Hi,
I faced same issue in one of my scenario.
It is not working well when i started sharing screen.
Now it is creating a very big issue for us when we are trying to show designed scrits.
As of now we are recording and sharing.
UIpath Team should consider this issue.

Hi,
It depends on screen sharing app. if your sharing thru Skype for business provided uncheck the visible and wait active in On element appear activity. it works good
even in WebEx it works well I think

1 Like

I don’t understand why it doesn’t work for me too. Because, on previous sessions when I shared my screen with Skype business my robot worked.
However I didn’t used community version of UiPath (UiPath Platform), is it possible that according to the version of uipath the robot work or not during screen share? Or is it due to the UiPath update 19.2.0?
Thanks

I Guess previously you were doing the Excel r PDF autmation, now trying to share the UI automation,
sharing the screen while UI automation is running is cause of the issue here, the Skype selectors are overtaking the Browser/Windows application selectors

No previously that was too on a web application, that’s why I don’t understand.

If you use On element activity , probably it wont work when u use skype messenger or any recording apps (PowerPoint) . But the workaround for this issue is uncheck the wait visible and wait active options by giving more delay timeout.