UIPath has stopped working - OCR


#1

Dave Burns
July 21, 2016 12:55 ANSWERED
Hi

Does anyone else have the error

This happens quite regular and it makes the scheduled runs very un-reliable.

Thanks

Dave


Exception thrown: Executor ended with exit code -1073741819 - OCR Loop
#2

Andrzej.Kniola July 22, 2016 11:46
Hi Dave,

Haven’t seen it crash like this in a while (since 8.0/early 8.1 I think).

Some questions:

Which UiPath version you are using? If it’s anyhing below 5973 it might be a heap corruption.
What are the system specs (win version, .net etc.)
Is there anything in event logs?
Is this related to a particular workflow, or activity, that you could pinpoint?
Is this only happening on unattended runs, or runs from Studio also crash?
Some things to try:


Enable tracing in UiPath (might become a memory hog if you can’t pinpoint the issue and need to run for a longer time) - http://www.uipath.com/kb-articles/how-to-collect-traces

Regards,

Andrzej


#3

Dave Burns July 22, 2016 15:15
Hi Andrzej

I’m running the latest UIPath version 1.6040, its running on a dedicated PC with 12Gb of memory thats running Windows 8.1, it might be an idea to upgrade it to 10.

I have had it processing over 1000 index files this morning, watching it ittemitantly and I have had that messagethree times.

The log file shows nothing out of the ordinary.

I will upgrade to win 10 to see if that stops the error

Thanks

Dave


#4

Mihai Badita July 26, 2016 16:44
Is there any OCR involved in the process?


#5

Dave Burns July 26, 2016 16:47
Hi Mihai

Yes quite a lot because it has to extract values from a VMS screen accessed through a RDP (citrix) session.

Thanks


OCR in a loop - Executor has ended with exit code : 1073741819 and Code : 255
#6

Mihai Badita July 26, 2016 16:55
This is a known issue regarding using Microsoft OCR in a loop which is causing random crashes in some conditions.

In the meantime, the workaround is to extract the bit that is scraping in a separate workflow and use Invoke Workflow with Isolated option. This will execute the critical part in a different process and, when the crash happens, it will actually close just that process, returning an error in the caller workflow.

The next UiPath version will provide an improved architecture for OCR operations - they will run out of process. Till then please use the workaround.


Image exists does not time out?
Beginners trouble - loop that ends too quickly
#7

Hi there, a year down the road, same error (in a similar context) - any idea if this has been solved (and something else causes the crash), or is it still pending?
Thanks,
Radu