UiPath execution in virtual machine

Hi guys,

I am building a bot using UiPath studio on a virtual machine. The bot is about logging into an application and importing an excel file into the application. The individual steps in this bot work just fine, but when I run the bot as a whole, the application often gets frozen after the file is imported.

I created another bot of excel automation, similar issue happened: individual steps work and the combined bot makes Excel frozen.

Does anyone know how to fix this issue? Thanks a lot in advance!


Hi @Abigail_Zhang

Did you try to add an delay between import steps?

Thanks, Andres. Yes, I added delay before and after clicking the import button but the problem still persists.

You´re welcome,

You can also try the following:

  • Using a short path for your file.
  • If you have your file in a shared drive, copy the file into a local directory, and upload from there to the application.

I hope my suggestions works for you, it is difficult with scarcely details to get an accurate answer

Hi Andres,

Yes, the path is reasonably short because it is saved locally on desktop. I will try other tricks and see whether the bot will work. Thank you so much!

The problem is solved by adding a delay right before clicking on the import button.