UiPath don't seem to recognize Excel on my computer

Hi! I am making progress on a process, but when I want to write values from a data table to excel using the Excel Application Scope i get this error:


Source: Excel Application Scope

Message: Error opening workbook. Make sure Excel is installed.

Exception Type: System.Exception

An ExceptionDetail, likely created by IncludeExceptionDetailInFaults=true, whose value is:
System.Exception: Error opening workbook. Make sure Excel is installed. ----> System.InvalidCastException: Unable to cast COM object of type ‘Microsoft.Office.Interop.Excel.ApplicationClass’ to interface type ‘Microsoft.Office.Interop.Excel._Application’. This operation failed because the QueryInterface call on the COM component for the interface with IID ‘{000208D5-0000-0000-C000-000000000046}’ failed due to the following error: Interface not registered (Exception from HRESULT: 0x80040155).
at System.StubHelpers.StubHelpers.GetCOMIPFromRCW(Object objSrc, IntPtr pCPCMD, IntPtr& ppTarget, Boolean& pfNeedsRelease)
at Microsoft.Office.Interop.Excel.ApplicationClass.set_SheetsInNewWorkbook(Int32 RHS)
at UiPath.Excel.WorkbookApplication.StartNewApplication()
— End of inner ExceptionDetail stack trace —
at UiPath.Excel.WorkbookApplication.StartNewApplication()
at UiPath.Excel.WorkbookApplication.InitializeExcelApp()
at UiPath.Excel.Activities.ExcelApplicationScope.<>c.<.ctor>b__44_0(WorkbookArguments args)
at UiPath.Excel.Activities.ExcelApplicationScope.Execute(NativeActivityContext context)
at System.Activities.NativeActivity.InternalExecute(ActivityInstance instance, ActivityExecutor executor, BookmarkManager bookmarkManager)
at System.Activities.ActivityInstance.Execute(ActivityExecutor executor, BookmarkManager bookmarkManager)
at System.Activities.Runtime.ActivityExecutor.ExecuteActivityWorkItem.ExecuteBody(ActivityExecutor executor, BookmarkManager bookmarkManager, Location resultLocation

I can’t find anything wrong with the registry as displayed in the pictures. I have also tried reinstalling Office, UiPath and using the modify function to repair Office. No luck. Is there any known fix to my issue? I am using Windows 10 with Office 365.

Hi @Nekrom,

The error message showing excel is not installed in your machine, can you check excel is installed in your machine or not?



Please check whether excel was properly installed in your machine or not.

If you want you can use Workbook activities. For this no need of Excel application to be installed in our machine.


Excel is installed and working perfectly on its own.


May be problem with UIPath.Excel.Activities package version you installed. Try with some other versions.


Tried to use several older versions back to 1.2, same result.


Use Workbook activities. For this no need of excel application to be installed in our machine.

Yeah, I guess that is a workaround! Still sad that I don’t know how to fix this problem though, and be use the Excel.Activities package :slight_smile:


If you are using Enterprise edition with license then raise support ticket in UIPath. May be they will help you.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.