Excel AddIn Error : Something went wrong with Excel

Hey, I’m new to UIPath and I have been getting the following error when trying to open Excel Sheets:

Something went wrong with Excel .
Activity Use Excel File ( Excel Application Card ) failed:

Error opening workbook. If Excel is installed, run the ‘Repair Tool for Microsoft Office Interop’ from the Tools tab on the Home screen. Unable to cast COM object of type ‘Microsoft.Office.Interop.Excel.ApplicationClass’ to interface type ‘Microsoft.Office.Interop.Excel._Application’. This operation failed because the QueryInterface call on the COM component for the interface with IID ‘{000208D5-0000-0000-C000-000000000046}’ failed due to the following error: Library not registered. (Exception from HRESULT: 0x8002801D (TYPE_E_LIBNOTREGISTERED)).

You can find the activity following this path:

Main > Use Browser Chrome: Find Unicorn Name > Use Excel File.

Excel file path: [string.Format("{0}\name.xls", Environment.GetFolderPath(Environment.SpecialFolder.DesktopDirectory))]

I tried using the repair tool, reinstalled Office and also tried some registry hacks. Can someone please help me out with this?
Thanks in advance!

This error is popping in more nowadays in Forum, did you have a look at the below knowledge base?

Error message: Error opening workbook. Make sure Excel is installed - News / Knowledge Base - UiPath Community Forum

Thanks, this worked!

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.