Uipath datatable

I am using build datatable activity. When I try to add column it is giving me this error message

“Datatable could not be saved. Please check the column types.”


Hi @icehouselux !
What are the types of your columns ? If you don’t mind, a screenshot would help

I’m having the same issue and I’m not building my datatable any different than in the past. I’ve tried updating packages and re-launching uipath without any luck.

Please share a snapshot of datatable or more details about it.

It appears the issue is tied in with the latest UiPath.System.Activities update 21.4.0.

When on updates up to 20.10.4, the Build Data Table activity works as intended - You can create a new activity, open the builder for the datatable, and are able to save changes without error.

Immediately upon upgrading to 21.4.0, you can create a Build Data Table activity, but when trying to simply open/close the builder you get the following error:


Downgrading to 20.10.4 resolves the issue, however this is not ideal as 21.4.0 brings several improvements that are desirable. This needs fixed ASAP.


21.4.0 works fine for me, idk

Same as @nameless it works fine with me, but interesting. What is your Uipath Studio Version ? Community or Enterprise ? Studio Pro or Studio ?

Currently we’re on Enterprise Studio 2019.10.2. We’re in the planning stage to upgrade Orchestrator/Studio to the latest version, but aren’t there yet.

Alright, I only experienced upgrade from 20 to 21.
But as you are an Enterprise user, your voice might be heard better if you open a ticket here

@scott.booher can you please share what Studio version are you using and a project with the issue replicated?

If not able to share the project please share the whole dependencies tree where we can check what dependencies you have added to your project.

Sorry I was out on vacation shortly after my last posting and just got back. I can’t share the project, but I stitched together the whole dependency tree and threw in the installed packages.

The tree/packages are with the issue present - datatables cannot be saved after opening the build wizard, even if it’s a brand new activity dropped into the project.

Edit: I plan on upgrading to the newest stable Orchestrator / Studio version regardless of what comes out from this, but I’ll help out with info until that’s done.

IssueScreenshots.7z (262.6 KB)

Hi @alexandru

Is there any update on the issue with the Build Data table.
We are using 2019.10.3 Enterprise License and facing this error. This is not run time error but pops up when Build Data table activity is launched and clicked ok without making any changes to any of the columns.

Hi @alexandru

Also want to request an update. We are using Studio 2020.4.3 with an Enterprise license. Data tables cannot be edited at all through the Build Data Table activity. I have attached a screenshot where you can see I did not even attempt to make any changes to the default data table. I simply opened the editor and clicked Ok and it errors. Any changes made also result in this error message but i wanted to prove that it was not a result of the changes made and it happens with the default.


1 Like

Hi @AlcBrk
I found another thread with similar issue but the error pop up is “DataTable Could not be read. Column types might not be supported” (link below). I’m getting same error as yours, I wonder if the both the errors are not the same.

If i downgrade Uipath.System.Activities to anything below 21.4.0 i’m not getting this error but other activities are getting effected

I hope someone from UiPath looks into this

There are 2 rows by default present in the data table, please delete one row and click on ok. Hope this works.

I have tried your solution, but still not working.

Hi @herman

downgrading Uipath.System.Activities package to anything below 21.4.0 is not giving this error. May be you can try this

@icehouselux hey have you solved this issue? I am also facing this issue suddenly. I am trying to add a new column using Build Datatable activity and I am getting the same error.
Uipath Studio version: Enterprise License Studio 2019.10.4
Uipath.system.activities used is 21.4.1
I tried downgrading the system activities but it is making my entire code with invalid.missing activity.

Please help!!!

While this is done it is affecting my entire project with Missing/Invalid activity error throughout.

I did face similar issue, as a workaround i didn’t change version in the actual workflow, I created new process with just build data table activity (version lower than 21.4.0) modified as per my requirement and copied it to the actual workflow.

For time being this solved the issue but definite not a long-term solution