UiPath Data scraping - "This control does not support data extraction"


I’m attempting to use the Data Scrapping feature in UiPath but keep getting the below error message. I’ve tried IE and Chrome and with no success.

“This control does not support data extraction”

I’ve tried restarting my machine but that did not seem to resolve the issue, any suggestions on how to fix this.


Did you installed chrome extensions?
If not please install extensions, restart and try again.

I had already installed Chrome extensions but that didn’t seem to resolve it

HI @Supernova, On which website you are trying to scrape the data ? or attach screenshot ?

You can refer,

I’m in the process of completing one of the exercises in the online tutorial

The site contains structured data and should easily be scrapped.


You can try two ways here,

  1. Select the two Selectors with same HTML pattern under WIID and give column name. Like this do for all the column’s in the Web table.

Refer Screenshot:

2) Uninstall and Re-install the Chrome extension

If you are still facing the issue try it on Internet Explorer :wink:


It doesn’t actually allow me to chose a selector. when I select “Data Scraping” > “Next” my cursor does not allow me to choose a selector. The whole page is selected see below, I’ve tried on both browsers and its the same result.

check again , have u installed google extension ? is selectors or working in other pages like login and dashboard ?

I think you are using edge browser . try it on chorme or IE

Google Extension is installed and i’m using IE 11

Yes, I have to hold the cursor down to highlight them.

Actually no selectors are visible when i click on the “Edit Selector” option


Uninstall and install UiPath studio again. It will help you :+1:

Go to acme login page try type into activity and click activity. so we can find whether it is scraping issue or extension problem. if you cant do type into and click activity then it is definitely extension issue.

It’s all very strange, I already have UiPath Chrome extensions enabled but keep getting this error message. I’ve tried uninstalling the extensions and reinstalling it but keep getting the same error message

If Chorme extension installed ? Try use chorme browser instead of IE …

You can install chrome extension and use chrome browser for data extraction.

I was having the same issue but when I checked I was trying to extract the URL from the incognito windows where the extension was not enabled to make sure the extensions are installed and enabled properly or try to open and extract the data from the non- incognito window.