UiPath.Cognitive.Activities.Text.Analysis.GoogleTextTranslate

Hi,
I am new to this platform. Building a project to read an excel sheet and translates one of its field to another langauage. (eg. from english to arabic ).
Am trying to use google text translate. see below function
UiPath.Cognitive.Activities.Text.Analysis.GoogleTextTranslate

Studio is asking for ‘Key’, what it means ? what value should I enter here ? Is it a paid key, if yes how can I get it ?

Please help

all the cognitive activities require an API key in order to be used within workflows

In the properties, you have a field Key.

How to get an API key -
https://developers.google.com/places/web-service/get-api-key

In order to create a Google Translate API Key you need a paid account.
The Cloud Translation API is priced monthly based on usage. Translation usage is calculated in millions of characters, where 1 million = 106 characters.

Prices per month

0-1 billion characters
Translation $20 per 1,000,000 characters*
Language Detection $20 per 1,000,000 characters*

If you pay in a currency other than USD, the prices listed in your currency on Cloud Platform SKUs apply.

  • Price is per character sent to the API for processing, including whitespace characters. Empty queries are charged for one character. Google charges on per character basis, even if the character is multiple bytes, where a character corresponds to a (code-point). For example, translating “こんにちは” to English counts as 5 characters for the purposes of billing.

Google Cloud Translate API Pricing

Through their terms and services, Google doesn’t allow for non-paid usage of their Translation API.

If you have Paid Account you can follow Below Link:

https://translatepress.com/docs/settings/generate-google-api-key/

Regards…!!
Aksh

I’m using a trial of google cloud services and have downloaded an API key, but I’m still having issues getting the activity to work. How do I use the key? When the parameter asks for the key as a string, what is that? is that the file path to the JSON key file; the value of the “project id” field; the “private _key_id”?

I have tried each of the above in the key parameter field, including the value of “private_key_id” with, and without the “-----BEGIN PRIVATE KEY-----” and “-----END PRIVATE KEY-----” and I always get the same error.

The activity appears to work, but when I put in a writeline activity to output the raw result I get this:
{
“error”: {
“code”: 400,
“message”: “API key not valid. Please pass a valid API key.”,
“status”: “INVALID_ARGUMENT”,
“details”: [
{
@type”: “type.googleapis.com/google.rpc.Help”,
“links”: [
{
“description”: “Google developers console”,
“url”: “https://console.developers.google.com
}
]
}
]
}
}

Can someone help?

Many thanks.

I figured it out: the key I was trying to use was a ‘Service Account Key’, not an ‘API Key’, so no wonder it didn’t work.

To get the API Key I navigated to ‘APIs & Services’ > ‘Credentials’ on Google Cloud Services, clicked the ‘create credentials’ button and selected ‘API Key’, then I had a key that worked. I just had to paste that value into the ‘Key’ parameter field of the activity and Bob was my uncle.

1 Like

Hey @Foehl

That sounds really Cool :slight_smile:
Keep It Up…!!

Keep learning, Sharing and Growing :slight_smile:
Regards…!!
Aksh

1 Like

Hi,

I want to translate text from Japanese to English using UiPath. I try download the package for google translate and use it but the key that I got from internet (Microsoft azure website) for google translate did not work. I have search for another ways to translate the text and I found one of the ways is to use text translator activity or document translator activity. However, I cannot find where the package for that activity to be downloaded. Can anyone help please?

Hi,

I have the same problem and I have try your method but it say I need to pay for the key. Can you please help?

Hi @Aoyama. To use it I had to sign up for a trial session. It gave me a trial credit of $300 (or something like that) which you can use to ‘pay’ for the services you use.

Just make sure you keep an eye on how many requests you make so you don’t go over your free credit :smiley:

Okay, thanks :grinning:

Hi All,
Facing issue while installting the package ‘UiPath.Cognitive.Activities’

Has anyone faced/facing similar issue, please guide to resolve.

Thanks

Hi @Vinod_Swain

Could you double check that nothing is blocking your connection to the feed?

Hi,

Am sure network is not issue as tried in both Office and home network.
For none of the other packages, am facing any such issue.

Can you please assist to get .nupkg link to download, so that same can be imported into studio.

Thanks

This is strange.

As to the packages, you can always access the packages here:

Please also see here to double check for all permissions that Studio and Robot need to work properly: