UiPath can be bend by this f* screen from Windows OS ?!

I want to automate a Remote Desktop Connection. For that, I’m trying to add a Click activity to “More choices” button in Windows Security screen which is automatically opened across the Remote Desktop Connection I’m looking to automate.

Bellow the screen / workflow :

Another error, trying to Type in password field.
I even didn’t reach that field because… “field not found”, as Check App State reported. See bellow :

try to run on debug mode , and see if the sreen pop up after or before the "click"activity


kindly try indicating different field in that pop up and give a try


@Ahmad_Rais : pop-up before “click”.
@nikhil.girish : no other element to interact with is possible (it’s an issue related to this special Windows Security type of windows).

Maybe someone tried before to automate this specific Windows Security pop-up window ?!

Hi try to use diffrent framework to indicate ,

nad if not possible then might need to use CV

this also happens to me before on pop up of google chrome

@Ahmad_Rais : I’ve spent all day playing with CV. Not getting through that screen.

Tried also with Local Group Policy Editor on Remote Machine to disable that screen, but no success. I do not depend of this scenario involving this screen / RDP single license route, but

I cannot belive that UiPath can be bend by this screen !
Even by another screen from Windows OS later found :