UiPath Apps - Connection to Apps service is lost

My uipath app showing connection to app service is lost, and window goes unresponsive.
How to correct this problem.

Hi there,

Can you share your Cloud account name? What geo are you based out of? Is the issue specific to this app, or any app you create?


1 Like

I am from india and my id is UiPath
Its only on specific app that contains more than 30 pages

@Jsaroj ,

are you still getting this error?

Not able to work from last 2 days

@Jsaroj ,

OK, what about others apps?

May be shared the details as @evan.cohen asked you.


1 Like

Hello @Jsaroj,

Are you still stuck with this problem? If you still do, could you please share the app? Our dev team can investigate it further.


Yes sir still not able to edit
How to share my app to you???

HI @Jsaroj

You can DM be the app after exporting it.
You need to click on three dot icon next to your profile button. Then you can click on export app menu. You will get an .uiapp file. You can share with me.


@Jsaroj ,

you can export and attach here too.

When saving Apps from App Studio , the following error message can occur:

Connection to Apps service is lost.

Possible cause

  1. You’ve lost internet connection. Apps requires an active internet connection to save changes you make to your app.
  2. The reason for this error can be the fact that the App service uses WebSocket to save the App definition.


First, ensure that you have an active internet connection. If you are still facing issues, then:

  1. Allow apps-socket.uipath.com to have long live connections by making sure you have the connection: Upgrade parameter in the header. This must be done with the help of your IT team.
  2. Work with your IT or network team to understand how WebSocket traffic policies are being handled and alter them as needed.
  3. Allow WebSocket connections by making sure that apps-socket.uipath.com is not added to your proxy policy. This must be done with the help of your IT team.

Open a Support Case with the following info if you are still encountering the same error after steps 1-3:

  1. Provide your Automation Cloud URL: UiPath
  2. Reproduce the error while generating a HAR file
  3. Export the App (if possible)