UIPath and Infor Mongoose SyteLine issues

I am trying to automate a process that uses the application SyteLine from Infor.

These are the scenarios:

  1. Failed scenario:
  • BOT initiates the process from the very beginning.
  • BOT logs into SyteLine and opens a form.
  • BOT tries to put information into the filtering fields.
    BOT is unable to find the matching selector for any of the fields.
  1. Successful scenario:
  • Developer initiates the process from the very beginning.
  • Developer logs into SyteLine and opens a form.
  • Developer starts the BOT at this point.
  • BOT successfully inputs the information into the filtering fields and is able to retrieve the needed information.

I have tried recording from the start, and as soon as I reached the form, it sees the section on the screen as a single pane (the ui explorer shows the section as ) and not each individual object on said pane. (Tried basic, desktop, web and native citrix recording).
When I navigate to the form, the native citrix recording works.

Tried to install the citrix extension. Received the “error #14 could not read Citrix registry key” since there is no citrix on the computer.
Tried the Java extension. This allowed some of the recorders to work (basic, desktop), but again when I made it to the form, Studio only saw a single pane.

Just wondering if anyone has come across this before and if there might be a fix. Unable to get to specific or add a xaml because of client confidentiality.

I have found out that SyteLine is built with the Mongoose tool.

After talking with UiPath support, the selectors were never properly shown while running the BOT. Three workarounds were found, though they were not ideal (ordered best to worst).

  1. Used Computer Vision to see each field.
  2. Click Image - selected a small area, including the labels and part of the text box, to in the text box area before typing.
  3. Tabs - used tabs to navigate between fields.

When needing to extract data, exported it to a csv file and used data tables to search what was needed.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.