Uipath 22.10.3 control java application

The content of manual mode listdata will change by hand operation, but use uipath click will not change.

By hand click above 8423.09, bottom number will change 8423.09
but use uipath soft click ,number don’t change.

HI @mawei2

Can you explain more about your question?


I add image info

What do you mean by soft click? @mawei2

Use uipath click activty

Hand operation bottom number will change。


How did you try to click have you enabled simulate click in the click activities properties?


I tried it,but Prompt simulate not available

Have you tried with classic click activities? @mawei2

I tried it, classic click activities ,number not change.

Use application
Show info
Is it related to these parameters? They are automatically generated

“-Xmx512m -Xms32m “”-Xbootclasspath/a:C:\Program Files (x86)\Java\jre6\lib\javaws.jar;C:\Program Files (x86)\Java\jre6\lib\deploy.jar;C:\Program Files (x86)\Java\jre6\lib\plugin.jar”" -classpath ““C:\Program Files (x86)\Java\jre6\lib\deploy.jar”” “”-Djnlpx.vmargs=-Xmx512m -Xms32m"" “”-Djnlpx.jvm=C:\Program Files (x86)\Java\jre6\bin\javaw.exe"" -Djnlpx.splashport=61418 “”-Djnlpx.home=C:\Program Files (x86)\Java\jre6\bin"" -Djnlpx.remove=false -Djnlpx.offline=false -Djnlpx.relaunch=true -Djnlpx.heapsize=33554432,536870912 “”-Djava.security.policy=file:C:\Program Files (x86)\Java\jre6\lib\security\javaws.policy"" -DtrustProxy=true -Xverify:remote -Dsun.awt.warmup=true com.sun.javaws.Main C:\Users\mawei\AppData\LocalLow\Sun\Java\Deployment\cache\6.0\33\30b4c561-7a77f6dd"

To enable it go to Activities-> Filter-> Show Classic(In your project)

Classic activities can be used without use application too

This is the one you used?


modern click
and classic click
I both tried it. Both not change data.

Hi @mawei2 ,

Could you explain in a bit more brief as to what you are trying to perform ?

Are you not able to perform the Operation with UiPath Activities but manually it is possible ? If Manually it is possible, could you let us know What are the Steps involved ?

Since you did mention it is a Java Application, Maybe also try installing the Java Extension and performing the steps.

Let us know what steps you have tried and provide a feedback.

Still haven’t solved my problems?
Who can help me?

I found that it is related to the clicked element. The element is in a panel and must be clicked before it can be changed. However, as long as the row or cell is clicked, it will become invalid.

Hi @mawei2 , do you thing we can get some sort of demo version of the app, without any sensitive data?
If not, maybe you can share a recording of when you do the click manually and when you use the robot to do the click for you.
Fell free to continue this conversation at this email address: vlad.coteanu@uipath.com