Pyauto python script not working with Uipath


I’m trying to run a python script and I get the flowing error:

This is the xaml and python script.

PythonPyAuto.xaml (7.1 KB)

import pywinauto‘right’,coords=(200,5))

Anyone can give me a hint about how to solve this?


hope this would helpyou

Cheers @Victor_Stanescu

Why don’t use the same click activity in UiPath @Victor_Stanescu?

I hope the python activity here won’t do some print or the GUI activities when we run in UiPath. It will process the steps of code we give and then return the result.

Yah i hope we can go for simple CLICK activity if possible with property simulate click enabled
Cheers @Victor_Stanescu

I need to do a right click on a Java application and the Uipath activity does nothing when working unattended, with closed VM.

I have tried to right click with the send window message selected, and I know that right click doesn’t work with simulate click option. I also tried to send the general hotkey shift+F10. Neither of those worked.

1 Like

i hope right click would work on a JAVA Application
–make sure that JAVA extension is installed
–then use a click activity with property Mousebutton choose as BTN_RIGHT from the drop down
–make sure that the simulat click property is enabled

kindly try this and let know for any queries of clarification
Cheers @Victor_Stanescu

I done all that you said, but this is how my selector looks:

Please look at my click activity setup:

I also tried to Simulate click but it gives me an error.

is the title attribute value is replaced with wild card at right position though you have used wildcard, kindly validate once whether it is placed correctly
–may i know what was the error
–make sure that this click activity is used inside a attach browser or attach window

Cheers @Victor_Stanescu

Please see the error when I enable simulate click activity:

I also put the wild card for the title