UiPath 2018.2.2 package is not working in Version 2018.1.4 for UiPath.Core.GenricValue

activities

#1

Scenario & Repro: We have developed a process which has generic value variable and done data operation of replace which worked in Version 2018.2.2 but not working in Version 2018.1.4. So finally we installed 2018.1.4 and found the error(‘Replace’ is not a member of ‘UiPath.Core.GenricValue’), fixed it by converting the variable to string value and done replace operation.

Current Behavior: The invoked workflow ‘XXXX’ has validation errors. Please review the workflow and resolve the errors.

Expected Behavior: UiPath.Core.GenricValue functions need to be updated in older versions


#2

This is an expected behavior.


#3

Hi Gabriel,

We expected it will work but unfortunately while deploying we got this error. Is there any plan to fix this or we have to upgrade the production robot every time when there is a release.

Regards,
Sharath.K@avasoft.com
AVASOFT


#4

If you develop a workflow with a newer version of studio, robots will need to be updated as well, to the same version.
we don t offer forward compatibility.


#5

@Sharathk Try this once in the project folder delete Json file and run so it will generate new json file