UI Elements acting up!

Good day everyone , please assist in crisis here, so these elements were working before but now the ‘select Item’, does not want to select that item there it just skips it and goes to this next field :

and on this field it doesn’t even type a correct thing, instead it types what it’s suppose to type in this activity here:


I tried starting from scratch and recapture them, selected fuzzy and changed again to strict selection but nothing.

Anyone please help

Hey @Anelisa_Bolosha ,

Before selecting the values just try to put click activity for the down arrow of the select box.


The down arrow for the first select is not working , so you just click on the field then there are options on the drop down to select from


Can you try checking your selectors please…looks like they are not very precise…try running in debug and use highlight element activity if it highlights the right select item when running …may be its identifying something else or there might be some invisible elements…or a second window open…


Hi, I did put the click then after the ‘select item’ activity but still not working

Are you getting any error?

no but it just clicks and doesn’t go to select item, it goes to another field

Please share the selector for the Select Item field, might be you are missing something in the selector.

I omited that htmlwindow but still not

here is the property options , and I used the ‘image exists’:

You need to make the changes in your selector, select any value in the Product drop down and then capture the selector and share it again


This value here doesn’t change it’s always the same
it’s this one below that is dynamic depending on which value it picks up :


I was able to solve this thank guys

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.