Typing @ doesn't work

I can’t type @ in studio, which is a problem when setting parameters for database activities, where I need to use @ before my parameters.
Steps to reproduce:

  1. Open studio
  2. Create new variable
  3. Attempt to use ALTGR+2 to enter @ in the default value (copy-pasting is a workaround)

Hi @kbak

Have you tried shift + 2 for @.


That gives me double quotes.

For danish keyboards on windows and linux, you press alt-gr+2 to do a @.

Hi @kbak ,

I could reproduce your error on my end, and it really seems a Bug.

What I did to fix it was closing the project, changing my license to Studio (was using Studio Pro) and then changing it again to Studio. After that, opening the same workflow and sending AltGr+2 on my keyboard, typed correctly the “@” symbol.

My steps were a bit random, restarting UiPath seems to solve it, temporarily.

Also a check you can do: if you type Chr(64) on the immediate pane, does it correctly write “@”?


1 Like

Chr(64) indeed works, as does copy-pasting,
I’m pretty sure it worked at some point, but I think since we last updated it still an issue. I’m on 21.4.4, and as we haven’t updated to 21.10 yet, I am interested to know if it is fixed in the latest version.

@kbak I could reproduce your error yesterday, but it was with the same version as you’re using, 21.4.4 :frowning:

On my end it was working correctly, it was just a matter of typing it multiple times, until at certain point, it stopped typing it.

I believe 2021.10 introduced some fixes to the special characters input. Could you please give the latest version a try, whenever you get a chance? :slight_smile:

1 Like