[Solved] Typing @ character into a VM is not possible

I’ve tried to use the Type Into and CV Type Into activities for typing an email address inside a VM with Oracle Virtual Box and also in Microsoft Hyper-V and with different OS: Windows and Ubuntu.

The result of the typing is the following:

If I do this image the result is the following: image no matter if I use the CV Type Into or just Type Into with focused field…

I’ve tried several workarounds but nothing seems to fix the problem… For example, I’ve used the Send Hotkey with Ctrl + Alt (AltGr in fact) pressed and the key 2. Also with Type Into and the combinations: “[k(alt)]2”, “[k(ctrl)][k(alt)]2”, “[k(lalt)]2” … etc…

Another thing I’ve tried is to send the Alt+64 but it didn’t worked also…

I’m going to put the solution I’ve found in the first answer to the thread, and I’m open to listen for more solutions if you have also!

The solution I’ve found and it works for all types of VM’s (Virtual Box and Hyper-V) and both OS (Ubuntu and Windows 10) is the following:
With the right alt pressed (d is the down modificator) I’ve pressed the 2 key and then leave up the right alt again. This solution works for Spanish Keyboard distributions only!!!

Lately I’ve found the following for US Keyboards also:

So you can use your imagination for the combinations in your own local keyboards… but the idea is clear.

I can imagine that this is not only for the @ character, but also for other ones, so this is a workaround for it!

I hope this helps to freaks like me that want to go beyond in automate different OS’s!!!


This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.