TypeInto produces '/' instead of '.'


#1

I am new to UiPath. Just opened the first example out of the Library to see how it is constructed and how it works. The example is the “Ping_Monitor”. When I run it it opens the console window (good) and then types the text into it (good), but in that text there are wrong charaters (bad). Instead of “.” it types “/” and I cannot seem to find any way to change it. I am on Windows 10, if that matters.

Any ideas?


#2

Hey @Gnum

Well i am not using windows 10 but for me on windows 7 it works.

May be check your character keyboard mappings per your language setup at the time of installation. it was ** English (United States)**? or else?

and you have tried manually with keyboard that you are getting it with uipath or if you will also type manually in notepad then also you are getting such behavior?

Regards…!!
Aksh


#3

Thank you Aksh for a prompt reply. Much appreciated!

My keyboard works normally everywhere, including UiPath Studio IDE. Following is the text I have in the Expression Editor for the TypeInfo property;

“ping microsoft.com[k(enter)]”

As you can see, I was able to type “.” where I needed it. When it is executed by Ui Robot (I assumed that it is) - it comes as “ping microsoft/com”, which obviously produces the result that is different to what was intended.

During the installation I have selected English (UK).

I will now try to find the settings of keyboard mapping you were referring to. Any new ideas on this are very welcome though!


#4

All that you’ll need to do is open your settings and set the language to English (United States), then remove the former one.

This can be done either by using Cortana - search for ‘region and language settings’ - or from the quick action bar, all settings, time & language, region & language.

From there, click on ‘add a language’, select English, then English US, and that should install from Windows update. Following that, delete the previous.

Now, if the language is showing up as US English, it is possible to set the keyboard layout independently. Simply click on the language, then under keyboard add US QWERTY to the list; then - again - delete the previous.

That should put everything how it should be.

and also you can try with this example as well and if it works for u as well then let me know :slight_smile:

Ping Monitor.xaml (13.2 KB)

Regards…!!
Aksh


#5

Thank you Aksh,
Unfortunately I cannot change my language settings on this machine as you suggested. There is some other software installed on it, which I also use. I need my OS-wide settings to be as they are. I was hoping to set up UiPath and to make it work for me. Do you think it would be possible to alter UiPath to cope with English (UK) being set as a language for Windows, or is it too much of a challenge for UiPath?


#6

Just had your sample opened and started. Following is what I get from it.

After that, I got error message with the “Null Pointer Exception” thrown by insides of the application.

Following is the content of the Log:

Ping Monitor has thrown an exception

Source: Write line

Message: Object reference not set to an instance of an object. This error usually occurs when using a variable with no set value (not initialized).

Exception Type: NullReferenceException

System.NullReferenceException: Object reference not set to an instance of an object.
at UiPath.Core.Activities.ScopeActivity.OnFaulted(NativeActivityFaultContext faultContext, Exception propagatedException, ActivityInstance propagatedFrom)
at System.Activities.Runtime.FaultCallbackWrapper.Invoke(NativeActivityFaultContext faultContext, Exception propagatedException, ActivityInstance propagatedFrom)
at System.Activities.Runtime.FaultCallbackWrapper.FaultWorkItem.Execute(ActivityExecutor executor, BookmarkManager bookmarkManager)


#7

character are replacing.

@moderators? any clue


#8

Why would my OS-wide language settings be applicable for keyboard input? I can see how “.” may be replaced with “/” for something like Date formatting, but for a straight typing of text from keyboard it does not make sense to me.

Regards,Alex


#9

Well lets see… because such issue never faced… so not much aware… with this behavior.


#10

I’m sorry to be the pain.

My guess is that me and UiPath just started from the wrong foot. :slight_smile:

Thank you for your help, anyway!

Cheers!
Alex


#11

Ok, I have found the solution to the first problem!

“ping www[k(decimal)]yahoo[k(decimal)]com[k(enter)]”

This produces the right typing into the console - “www.yahoo.com” - YAY!

Cheers!
Alex


#12

Great :slight_smile:


#13

@aksh1yadav UiPath.Core.Activities.ScopeActivity.OnFaulted(NativeActivityFaultContext faultContext, Exception propagatedException, ActivityInstance propagatedFrom)

what type of error is this?