Type into simulate type without automatic emptyfield

Hello,

I’m creating a long text file via loop where I put new information between constants. I use read cell and type into activities and it works.

Anyhow using the default type into is very slow as there are many pages of text to be written. Therefore I would like to use the simulate method. The problem is that it automatically empties the field and makes my loop unusable.

In the UiPath RPA academy the tutorial said that this could be fixed with gettext activity. How is that done?

Also it would be useful for me to use hotkeys as well. Currently I have them in my type into activity like this between the variables that needs to be written:
+"[k(enter)]"+"[k(tab)]"+
Is there any chance to use hotkeys via a separate hot key activity with simulate type TypeInto activity? This way my sequence would be like this: type into activity - hotkey activity - type into activity - hotkey activity and so on.

I’ve tried to do some research on this on my own but I haven’t found the solution yet.

Thanks,
Roope

@roope

You can use Send Hot Key activity to send Hot keys.

If you use Check simulate type property and try to pass hot keys then it will type those keys instead of sending. So when you trying to send keys make sure simulate type or send Window message should be unchecked.

1 Like