Type into browser url

I have a scenario with sso login.
So I go to Chrome right click and then select different user. When the new chrome browser appears, it is blank. I need to input the URL into Chrome. I was getting previlige error when I tried to click on the browser to enter URL. So I changed compatibility settings. I don’t know what is the reason though, I am still not able to type the URL into the new browser which was auto launched. The properties aren’t captured. Someone please help…

Just to be 100% sure: you have the chrome plugin installed, correct? It is needed for uipath to “see” the elements in chrome.

Can you expand on what you mean by “select different user”? Is this a google profile that you are signing in/out of? Or a different windows account?

For the ‘privilege error’ piece - this will happen when uipath opens the browser with elevated access, but the user does not have that same local admin or elevated access (or vice versa)

I am a sso user. So when I open Chrome my application opens and I am able to capture the properties . Now I want to login as a different sso user. My company sso I have logged in. So the steps involved to login as a different sso user are go to the chrome in desktop, shift + right click and there is an option in menu which says log in as a different user. So I use that option, then there is a window pop up to enter credentials post which a new chrome browser Automatically opens. So here is the problem. I need to maximize this second Chrome( on a different sso) browser and type into the URL box. Here I am not able to capture the properties. I can’t use open browser activity. I need to type the URL. The properties of this browser are not being captured at all.

Also, I have not signed out as the first user, I am just logging in as another user, for approving a workflow in chrome . It’s not a Google profile. It’s my company login sso.

UiPath won’t be able to access programs that are opened by a different user. It logs in using your own credentials (based on what is in orchestrator in the ‘robot’ settings). It doesn’t have the required permissions to use programs that other users opened.

It may be possible to fix this by giving the robot user elevated access rights (e.g. full local admin privileges), but that is not a guarantee.

Why do you need to use sso of a different user? Can’t you give the robot user access instead? If that’s not possible, does the application have a hidden way to login outside of sso? Oftentimes even with sso-enabled web apps you can “force” using different authentication methods

1 Like

Hi Dave,

Thanks a lot for replying and addressing the question. I was in need of an answer as soon as possible.

I needed a different user because my organization wanted to use it this way even though giving access to the current user as you have mentioned makes better sense. There is no hidden way to log in outside of sso here. I will mark the scenario as not feasible. Appreciate your time and very grateful for it. Thanks a lot once again.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.