Type into activity not inserting whole string

Hello everyone,

I have noticed lately that Type into activity has stopped working properly…It is inserting only part of the string in input field. I have tried to set different parametres, put delay between characters, but nothing solved the issue. It looks random, sometimes it insert whole string, sometimes only last three characters. It is happening with different applications in different fields.

I know there are various workarounds, however I used type into activity in few robots, and I dont want to replace all type into activities.

I was wondering if this happended to anyone else or its just me? is anyone familiar with the cause of this issue?

Thanks.
Nikola

Yes, I have faced this problem, I inserted a delay where ever the string is too long. I can’t think of any other solution.

Trim The variable using " " Space and vbCrLf to remove unwanted Space and Enter in the variable, Then Try using type into .

Hi nikola_kocourkova,

Things you need to do -

  1. Remove all the white space character from string , using trim function e.g. yourString.trim
  2. While inserting the string put a delay in keys option.

Regards,
SR

Copy your string variable to clipboard using set clipboard activity and then use send hot keys ctrl+V
Hope this will help :+1::slight_smile:

3 Likes

If the other mentioned work around not helps you, try Simulate Type checked.
I also faced this kind of unknown issue and got resolved by simulate.

Hi @nikola_kocourkova,

This issue is happening because type into is typing even before load of that control. Try adding some delay before and set WaitForReady property to complete. This should solve your problem.

Regards,
Tuhin

1 Like

That worked fantastically and solved a similar issue i had. Many thanks!!!

1 Like

@fernando321
Thanks for sharing your experience with us…