Type into activity not behaving properly when run from orchestrator

excel
orchestrator
variable
arguments

#1

I am using a Type Into activity to enter the filepath and filename for a ‘Save as’ dialog box. The filepath and filename is made up of parameters from variables and arguments in the workflow.

i.e.

recFolderPath + “”+currentComp+""+reportPeriod+". “+ reportMonth+”"+currentCompCode + “FXD” + reportMonth+ reportYearSave + “_Asset_Master_Listing”

where currentComp, reportPeriod, reportPeriod, reportMonth, currentCompCode, reportMonth, reportYearSave are variables read from an excel spreadsheet

The end result should be:

“\cngshsfs01cv\parra_fin_shared_services\Parra_Fin_Shared_Services\03 Fixed Assets\FY 17-18\01. Reconciliation\141 - Queensland Newspapers\12. Jun\141_FXD_Jun18_Asset_Master_Listing”

This output value is confirmed in the log statements

However, when it comes to actually populating the dialog box, the end result is full of random characters, symbols, and capitalisations that end up rendering the filepath and file name incorrect and unable to be saved.

Examples of some corrupted output:
ervices\Parra_fiN_Shared_Services\03 Fixed Assets\FY 17-18\01. reconciliation\133 - leader Newspapers\12. Jun\133-FXD_Jun1*_Asset_master_Listing

ra-fin_shared_services\Parra_Fin_Shared-Services\03 Fixed Assets\FY 17-18\01. Reconciliation\141 - Queensland Newspapers\12. Jun\141_FXD_Jun18_Asset-MasteR_Listing

\cngshsfs01cv\parra_fin_shared-services\ParrA_Fin_Shared_Services)# Fixed Assets\FY 17-18\01. Reconciliation\141 - queensland newspapers\12. Jun\141_FXD_Jun18_Asset_Master_Listing

_services\Parra_Fin-Shared_Services\03 Fixed Assets\fy 17-18\01. Reconciliation\141 - Queensland Newspapers\12. Jun\141_FXD_Jun18_Asset_Master_Listing

I don’t encounter this issue when I run the bot connected, only when running disconnected. I’m not sure why the values get corrupted when run this way.

Thanks again,


#2

There can be interaction between TypeInto and the machine’s configured IME.
Please check if an input method is configured on either the host or guest machine (disable it if possible)
Otherwise, you can try to put the string in the clipboard with “SetToClipboard” and then “SendHotkey” ctrl+v (although that is not a perfect solution, it should work if the clipboard sharing is enabled)