Trying to Automate Xstore by Oracle, but the recorder is not mapping

I am trying to automate Xstore test cases with UiPath to check its feasability, but the App recorder or computer vision, is not mapping the icons/buttons or any selectors properly. Can someone help with this?

P.S : tried changing resolution of the Xstore app, but same result.


Welcome to the community

if its oracle…may be does it run on java?

if yes then try to install the java extension before indicating



Yes I did, But still I am facing the same issues.


Did you configure it properly?

for java 9 and above there are additional steps needed…are those done as well?


I read the further instructions, buts its a bit complex.

" Add the previously created folder to the classpath of the target Java application. This is done with the -cp, -classpath command. For this example, we consider SwingSet2 the target Java application:

C:\Program Files (x86)\Java\jre1.9.0_xx \bin\java.exe -cp SwingSet2.jar;C:\UiPathJavaExt\* -Djavax.accessibility.assistive_technologies=UiPathJavaServiceProvider SwingSet2

If the application is started via a .bat or a .ps1 file, then the file must be analyzed with a text editor. The file that starts the application contains a line similar to the command java -jar SwingSet2.jar, but also includes many other parameters."

Can you explain this?
I have created a folder and put the required files in it, but ow to proceed.
Also target application is a Batch File.


How are you starting your application ? it is only for jar or ps1 type…did you perform other steps?


Yes, I performed the other steps stated below Java 9 and above

Is there any video tutorial or better step by step explanation available?