Trying to activate Power Shell window

Hi all,

The execution foresees that the robot opens the Power Shell window and writes on it a watchdog script.

I have the following issue: during the execution of the unattended job from Orchestrator, I’ve noticed that the robot is able to open the Power Shell window but it remains inactive so the robot is not able to write on it. I’ve tried Activate activity, Win + UP send hotkey, Attach Window but they didn’t work. Yesterday I had no problem about it, but few days ago and today I’m blocked in this issue. The problem doesn’t appear if I start the job in Attended way.

Any ideas?

Thanks a lot

Hi @etasca,

Have you tried making a window click before?


Hello @etasca

Instead of opening the powershell window you can try with the invoke powershell activity.


I can’t because i’m using a watchdog.

Now it is working, i changed from Orchestrator the following:

  • Resolution
  • Login to console: set to NO

Is it possible that those settings were correlated to the issue?

@etasca Resolution of the screen?? If yes then it can impact

Yes the resolution of the screen.

Is it possible that without setting it when the robot started in unattended way sees the VM desktop inactive?!

So are you open the powershell console in the VM and accessing from the local??

Yes, I open Power Shell with Open Application activity and than with a Type Into I write the code to activate the watchdog script

So the robot is running in your local and powershell you are openinh in VM ryt??

Then better to maximize the VM and open the powershell…