Robot status always disconnected

Hello guys,
i’ve a problem with my bot, the status is always disconnected. I try to run bot in a RDP
to which I am not connected.
If i open RDP i’ve seen the uirobot assistant is not open, if i open manually the robot turn in available.
How can i make it open automatically, in order to have the bot always available?

Hi @andreus91
There is an option to install the UiPath Robot in service mode. When you run the UiPathStudio.msi installer, go into “Advanced” installation and make sure that enable “Register as Windows Service”. See screenshot below.

When installing Unattended Robots, it is recommended to install the Robot in service mode. For Attended Robots, it is recommended to install the Robot in user mode (disable Register as Windows Service during installation).

Hope this helps…

1 Like

Thanks, that is very helpful, how can i manage that without re-installing uipath?

You can run the following commands in the command prompt with admin privileges:

cd “C:\Program Files (x86)\UiPath\Studio”
UiPath.Service.Host.exe install
net start uirobotsvc


Hi @Matthew_Tan
i’ve the same problem, i’ve tried to follow your instruction, the console appear but i can’t digit nothing (net start uirobotsvc)
Is possible to install the service mode with the CE or only with enterprise?

You are not supposed to double click that executable… just open the command prompt as an administrator and after that you type those commands…

1 Like

Hi @bcorrea,
i’ve tried to do that, “run as administrator” but i can’t type any command