TNS error while connecting to oracle database


#1

before posting this question i googled about driver providers, microsoft drivers inks, other errors related to connecting to oracle. i downloaded all the examples which attached in this forum for database related questions.

i am unable to connect oracle database. i need your suggestions. Below is the steps which i followed.
i have oracle 10g installed on my machine. i am able to connect thru sqlplus and toad.
i created DSN thru odbc tool on oracle home. and i am able to test the connectivity too. Connection successful.
i am able to connect to oracle using other tools like etl tools.
In uipath, i tried using microsoft driver, .net prvider for odbc method. itried using connection string or service.
in command prompt am able to test listner and tns name entries. and able to connect to database. I need to know why i am unable to connect thru uipath? why im getting tns couldnt resolve error? am i doing any mistake or is there any setup to follow? is there any documentation(i have gone thru activities and acadmey guides)? Please suggest how can i resolve this issue?

ORCL=(DESCRIPTION=(ADDRESS=(PROTOCOL=TCP)(HOST=xxxx)(PORT=1521))(CONNECT_DATA=(SERVICE_NAME=orcl)));
User Id=scott;Password=tiger;

“Driver={Microsoft ODBC for Oracle};Server=xxxx;Uid=scott;Pwd=tiger;”


#2

Please follow this:

Regards,
@therishirawat


#3

Already I tried that… I am able to connect to database with some another tools thru odbc. why not with uipath?


#4

What is the error you are getting?

If you can provide the details or screenshot?


#5

Downloads execution started
: ERROR [08004] [Oracle][ODBC][Ora]ORA-12154: TNS:could not resolve the connect identifier specified

ERROR [IM006] [Microsoft][ODBC Driver Manager] Driver’s SQLSetConnectAttr failed
Downloads execution ended in: 00:00:01

and another type of error is attached.


#6

i think… problem with 64bit. because when i connect to database thru toad(from program file(x86)) im getting tns error. But when i connect (from program files directory) im not getting any issue.

Any suggestions from your end?


#7

@badita i installed uipath in program files path(C:\Program Files (x86)\UiPath Platform). when i am connecting, i’m getting TNS error. After that i copied all the uipath files from x86 to program files(C:\Program Files\UiPath Platform) im able to connect to oracle database. Connection is successful. But when i run the workflow, it is giving tns error.

ERROR [08004] [Oracle][ODBC][Ora]ORA-12154: TNS:could not resolve the connect identifier specified
ERROR [IM006] [Microsoft][ODBC Driver Manager] Driver’s SQLSetConnectAttr failed
SOurce: Newtonsoft.Json error as mentioned above post.

Any ideas to resolve?