Throw execution problem. "Throw Faulted"

@aksh1yadav @badita
Hi, I’m hoping someone can help me solve this problem that is currently occurring in my robot.

I have several throws in Try-Catch blocks that when executed in debugging mode, shows “Throw Faulted”. The reason why I didn’t notice this earlier is because the error that occurred when throw was being faulted was caught by the Try-Catch block, so I didn’t see that it wasn’t the actual throw that gave the error.

I’ve however had Throws work when i first created this robot several months ago, and now during the test phase, they don’t work anymore.

I’ve tried creating a new project with only a Throw, where it also shows Throw Faulted.

I checked the log file of the robot and got this.

18:37:18.1882 Trace {“message”:“Throw Faulted”,“level”:“Verbose”,“logType”:“Default”,“timeStamp”:“2018-09-11T18:37:18.1882828+09:00”,“fingerprint”:"",“windowsIdentity”:“XXXXXX”,“machineName”:“XXXXX”,“processName”:“Test2”,“processVersion”:“1.0.6828.33465”,“fileName”:“Main”,“jobId”:“XXXXX”,“robotName”:“XXXXX”,“activityInfo”:{“DisplayName”:“Throw”,“State”:“Faulted”,“Activity”:“System.Activities.Statements.Throw”,“Arguments”:{“Exception”:“System.Exception: Exception of type ‘System.Exception’ was thrown.\r\n at System.Activities.Statements.Throw.Execute(CodeActivityContext context)\r\n at System.Activities.CodeActivity.InternalExecute(ActivityInstance instance, ActivityExecutor executor, BookmarkManager bookmarkManager)\r\n at System.Activities.ActivityInstance.Execute(ActivityExecutor executor, BookmarkManager bookmarkManager)\r\n at System.Activities.Runtime.ActivityExecutor.ExecuteActivityWorkItem.ExecuteBody(ActivityExecutor executor, BookmarkManager bookmarkManager, Location resultLocation)”},“Variables”:{“NewTransaction”:“False”}}}

This is the part where the throw is faulted. All the sensitive info has been changed to XXXX.
Other than this I’ve tried restarting the computer and checking previous backup files to see if the Throws work, which they don’t.

Due to security reasons, I cannot upload the Xaml file of the project.

Would be very helpful if someone can shed some light on what this might be.

Thank you

What value are you using in Exception property of Throw

Thank you for your answer.

I’ve written “new System.Exception()”.

Thank you