The Remote Certificate is invalid according to validation procedure

When i am trying to send mail using SMTP it is throwing error as shown below.

Source: Send SMTP Mail Message.
Message: The Remote Certificate is invalid according to the validation procedure.
Exception Type: System.Security.Authentication.AuthenticationException.

I Tried below solutions to resolve.

Disabled Antivirus.
Allowed Less Secure App from my gmail Account.

I have already read below UI Path topics but i didn’t find link to download the trusted certificate.

After 2 days I found out that there is some issue with this package

So I downgrade to 1.1.6382.14550, now I can get mail messages through IMAP without error out.
Any version newer then 1.1.6384.14550 will error out with this message.


@Chengwei_Tzeng, Thanks for the tip, it worked.

How to downgrade the package you suggested with the version number 1.1.6382.14550 of the package UiPath.Mail.Activities

Hi @pawan_dhail

Welcome to our UiPath Forum! :slight_smile:

See here on how to manage the packages: