The product is already installed on this machine. Therefore, the installer needs to be run silent mode(using the /Q switch). Setup will now exit

I cannot install due to attached error.
I tried silent install but the product has not been installed.

Hello @misa.oshima

Welcome to UiPath community…!

Can you please confirm no other version of studio is there in your machine? If yes and you need an another setup, please uninstall and reinstall the product.


Thank you for the prompt response.
Unfortunately, there is no other UiPath studio can be found in application.
I have restart PC but there is no change.

Hi I have the same problem. Is there any solution?

I get the same error, how should i uninstall the older version and reinstall the new one.
I already removed from the program and features in control panel.

@loginerror Can we get some help with this one? It seems this is a new issue that recently started happening, I haven’t seen any topics on this before.

Could you please try this solution, just with the latest installer?


Please try this

UiPathStudio.msi MSIINSTALLPERUSER=1 ADDLOCAL=DesktopFeature,Studio,Robot /Q


This worked, thankyou. I right clicked unintsalled and installed it. StudioX is now opened.

When I uninstalled it, it threw me couple of errors ( i couldnt capture them ). Then when i installed it worked.