Studio uninstallation issue

Please help me uninstall the studio version.

Existing post:
The recommendations in the link below didn’t work. However, the issue is the exact same.


How about upgrading to the latest version then uninstall?


@Prasad_Ashish If you need the MSI for that exact version of Studio, try this:

Hope it helps you! Thanks!

While upgrading it to the latest version, it says ‘A different version of the product is already advertised on this machine/ Setup will exit now.’

Please assist

I tried downloading the latest version and your link too. No luck as of now. Not able to uninstall or upgrade. It always throws an error.


Please check what is your installed version and try downloding it from orchestrator downloads page and then try uninstalling using that msi



The following topic may help you.
(Sorry but the following is Japanese document. Please use auto translation site etc.)


Did not find the registry for UiPath. No help as of now. Anyone, please assist.

Not able to uninstall the application.

Also, while opening the project, below error is seen:


Could not find the resource “UiPath.Activities.System.Properties.UiPath.System.Activities.resources” among the resources “UiPath.Activities.System.ViewModels.Resources.ActivitiesMetadata.json”, “UiPath.Activities.System.ViewModels.Resources.ActivitiesBindings.json”, “UiPath.Activities.System.ViewModels.Resources.Icons.add_data_column.svg”, “UiPath.Activities.System.ViewModels.Resources.Icons.add_data_row.svg”, “UiPath.Activities.System.ViewModels.Resources.Icons.add_log_fields.svg”, “UiPath.Activities.System.ViewModels.Resources.Icons.add_queue_item.svg”, “UiPath.Activities.System.ViewModels.Resources.Icons.add_transaction_item.svg”, “UiPath.Activities.System.ViewModels.Resources.Icons.append_item_to_collection.svg”, “UiPath.Activities.System.ViewModels.Resources.Icons.append_item_to_list.svg”, “UiPath.Activities.System.ViewModels.Resources.Icons.append_line.svg”, … embedded in the assembly “UiPath.System.Activities.ViewModels”, nor among the resources in any satellite assemblies for the specified culture. Perhaps the resources were embedded with an incorrect name.

Error: RemoteException wrapping System.Resources.MissingManifestResourceException: Could not find the resource “UiPath.Activities.System.Properties.UiPath.System.Activities.resources” among the resources “UiPath.Activities.System.ViewModels.Resources.ActivitiesMetadata.json”, “UiPath.Activities.System.ViewModels.Resources.ActivitiesBindings.json”, “UiPath.Activities.System.ViewModels.Resources.Icons.add_data_column.svg”, “UiPath.Activities.System.ViewModels.Resources.Icons.add_data_row.svg”, “UiPath.Activities.System.ViewModels.Resources.Icons.add_log_fields.svg”, “UiPath.Activities.System.ViewModels.Resources.Icons.add_queue_item.svg”, “UiPath.Activities.System.ViewModels.Resources.Icons.add_transaction_item.svg”, “UiPath.Activities.System.ViewModels.Resources.Icons.append_item_to_collection.svg”, “UiPath.Activities.System.ViewModels.Resources.Icons.append_item_to_list.svg”, “UiPath.Activities.System.ViewModels.Resources.Icons.append_line.svg”, … embedded in the assembly “UiPath.System.Activities.ViewModels”, nor among the resources in any satellite assemblies for the specified culture. Perhaps the resources were embedded with an incorrect name.
at System.Resources.ManifestBasedResourceGroveler.HandleResourceStreamMissing(String fileName)
at System.Resources.ManifestBasedResourceGroveler.GrovelForResourceSet(CultureInfo culture, Dictionary2 localResourceSets, Boolean tryParents, Boolean createIfNotExists) at System.Resources.ResourceManager.InternalGetResourceSet(CultureInfo culture, Boolean createIfNotExists, Boolean tryParents) at System.Resources.ResourceManager.GetString(String name, CultureInfo culture) at System.Resources.ResourceManager.GetString(String name) at UiPath.Studio.Plugin.Workflow.ResourceManagerWrapper.GetString(String name) at UiPath.Studio.Plugin.Workflow.Presentation.ActivityViewModelService.ProcessSynonymsForActivity(Assembly activityAssembly, ActivityInformation activity) at UiPath.Studio.Plugin.Workflow.Presentation.ActivityViewModelService.Initialize(ActivitiesContext context, Assembly activitiesAssembly, Assembly resourcesAssembly, ActivitiesAssemblyInformation activitiesAssemblyInformation) at UiPath.Studio.Plugin.Workflow.Project.Services.ActivitiesRegistrationService.ProcessActivities(IAssemblyInfo assemblyInfo, HashSet1 hiddenActivities, TargetFramework projectTargetFramework, CancellationToken token)
at UiPath.Studio.Plugin.Workflow.Project.Services.ActivitiesRegistrationService.ProcessActivities(TargetFramework projectTargetFramework, CancellationToken token)
at UiPath.Studio.Plugin.Workflow.Project.Services.ActivitiesRegistrationService.<>c__DisplayClass20_0.<b__0>d.MoveNext()
— End of stack trace from previous location —
at UiPath.Studio.Plugin.Workflow.Project.Services.ActivitiesRegistrationService.WaitRegistrationAsync()
at UiPath.Studio.Plugin.Workflow.Project.Services.ActivitiesRegistrationService.WaitRegistrationAsync()
at UiPath.Studio.Plugin.Workflow.Project.Services.ActivitiesRegistrationService.GetContextAsync()
at UiPath.Studio.Plugin.Workflow.Services.ActivityLoaderService.SetContextAsync()
at UiPath.Studio.Plugin.Workflow.Services.ActivityLoaderService.LoadActivitiesAsync()
at UiPath.Studio.Plugin.Workflow.Services.ProjectLoaderProjectEndpoint.b__10_0()
at UiPath.Studio.Plugin.Workflow.Services.ProjectLoaderProjectEndpoint.LoadFromContainerAsync()
at UiPath.CoreIpc.Server.<>c__DisplayClass7_3.<<-ctor>g__InvokeMethod|6>d.MoveNext()
— End of stack trace from previous location —
at UiPath.CoreIpc.Server.<>c__DisplayClass7_1.<<-ctor>g__HandleRequest|3>d.MoveNext()
— End of stack trace from previous location —
at UiPath.CoreIpc.Server.<>c__DisplayClass7_2.<<-ctor>b__5>d.MoveNext()
— End of stack trace from previous location —
at UiPath.CoreIpc.Helpers.Timeout[TResult](TimeSpan timeout, List1 cancellationTokens, Func2 func, String message, Func`2 exceptionHandler), HResult -2146233088

Is there any solution someone can recommend?

  • If all you need is to uninstall Studio, then you can simply run msiexec /x <path to the MSI file>.
    For upgrading to a new version (in order to preserve the user data) I’d suggest restoring that file and then upgrading.

  • If you’re unable to find the original MSI file, you can try using a third-party uninstaller program. These programs are designed to remove applications even if the original installation files are missing. Some popular uninstaller programs include Revo Uninstaller, IObit Uninstaller, and Geek Uninstaller.

  • If the above fails, you may need to manually remove the application files and registry entries. However, this can be a complex and risky process, so it’s generally not recommended for inexperienced users.

When the IObit Uninstaller is installed, go to Control Panel → Programs and Features, or in the IObit Uninstaller application choose to uninstall UiPath Studio.
In the end, the application and the registries left over should be removed and you can install a new version.

Thank you, the application has been uninstalled but I can still see it in the startup and open it as well.
Also, cannot install the latest version. It says “A different version is already advertised on this machine. Setup will exit now.”

Please help.

It seems that you installed multiple versions of the Studio in your system.
Try to restart the machine and then check which is the local path of the installed Studio in your Startup apps and then retry to uninstall it from that location.

Restarted. But not finding any uninstallation file in the location. Please help.

If you are an Enterprise customer, raise a ticket with support for future troubleshooting.

No Marian, I’m not.

I tried to install it with the existing version and ended up with the below error.

Installation error
“UiPath Studio Setup has encountered an error. Please check the log for the details.”
and I can’t understand the big long log file

Attach the txt or log file here to see more details.

MSIda6b6.docx (32.3 KB)
txt file was not allowed to be attached. So, I copied it in Word file and attached.

Please help

I have not yet got the solution but have been notified/forced to mark the topic as “Solved”. Please help even though the post is marked as solved.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.