The Element suddenly stops being identified

Hello!!
At first, my automation was working. Suddenly (some days after) it just stopped.
The activity that is “crashing” the automation is a simple click. Because it can’t find the element (Chrome address bar).
The full error:
image

I’ve tried to remove all the info from selector and just leave chrome app and title *, but doesn’t solve.
I currently changed the selector to:

…and that way it works. I really don’t know until when, because I frequently have to change this selector.
Is it normal? The same selector works now, but in 2, 5 days doesn’t?

Thanks.

Hi @vip.thsantos ,

Open this selector in UiExplorer and make it unique by selecting other properties.

Share the screen shot of Selector in UiExplorer.

Hi @manjula_rajendran .
I don’t really know how to use it, but there it is:

You can’t use wildcards like that, you’re making the selector not unique. Show us the selector without the wildcards, as UiPath gives it to you after you “indicate element.”

Hi @vip.thsantos ,

First select the element. Then do right click and open in UiExplorer. Here select indicate element and again choose the same element. It will show you the details.

Hi!!
I just did, but… Isn’t it the “same thing” as Edit Selector?


Or I just change something?

Hi @vip.thsantos ,

In your selector do the changes

  1. title=’* - Google Chrome’
  2. name= ‘* - Google Chrome’
  3. in fourth selector name = ‘*’

What is the value in text?

The fourth is “search and address bar”. The browser address bar itself.
I’ve changed and it worked. Suddenly stopped again. I’ll do the change you sent me and let you know soon.

1 Like

Hi again…

It still happens! It seems the robot tries to find a different thing, because the button the robot can’t find is in the same position it was 1 second before and it found the btn.
I have a sheet of (for ex.) 20 lines and what I need to do is to get the A1 cell and paste the value on my ERP. After that, click OK! Something like that.
The robot does the task 15 times. The 16º, it closes. And when I mean CLOSE, I mean close the UIPATH “executor”, or UiRobot (better).
If I run once again, it can (or not) run until the end. Let’s suppose it does. If I run tomorrow, is another surprise. haha!

It’s being hard.

Any ideas?

Are you able to use “Click image”? I’ve had success using that when elements vary like that.

Otherwise you may need to use “Find element” or “Find relative element”, storing a current element as a variable, and using that within your “Click” configuration.

I can see you are dealing with a Chrome widget and those are difficult to get the selector to the right layer, you might have to use a different activity… But as a possible solution i’d recommend you to use a “Attach window” around any other activities deployed on the chrome widget.

Uma screentshot da tela que você quer clicar ajudaria, mano.