Terminal session parameter


#1

Hello
I am in a japanese ibm mainframe project and we try to use uipath to connect to terminal.
we find a issue.
when the terminal default session parameter is 939,uipath can connect correctly.
but when we want to change the session parameter to 1390(unicode),uipath can’t connect to terminal any more.
we want to use 1390(unicode) session parameter to handle the terminal.
Have anyone ever experienced such a situation?
How to solve it?
Thank you.


#2

Hi

I am using IBM EHLAPPI connection provider to connect to mainframe. which provider are you using?


#4

hi
we use ibm pcomm


#5

Can you post the screenshot of the Configure connection window?


#7

i am sorry that the terminal is in the project internal environment that i can’t post the picture.
when the host code page of ibm pcomm session parameter is 1390(unicode),uipath can’t connect to terminal.


#8

Can you try changing the connection provider in UiPath to “IBM EHLLAPI” and point the pcshll32.dll file in PCOMM installation folder

//www.uipath.com/hs-fs/hubfs/KB_article/TerminalsArticle/Image_11.png?t=1531371992743&width=486&name=Image_11.png

This option works good for me than any other providers