Terminal: Field not found

activities
terminal
error

#1

Hey,

situation:

  • I’m working in an AS400 Terminal through IBM Ehllapi connection.
  • I’m recording the steps with the Terminal Wizard

Problem;

  • There’s one field in AS400 that I cannot seem to insert data into, I recorded it with the wizard but when I execute the flow, I receive the error that “the field is not found”

I checked this post that had the same issue, but the answer doesn’t work for me.

additional info:

  • I tried with “set field at position”
  • I tried with “move cursor”
  • I tried with “Set Field”

Nothing works… It’s so strange because the previous steps and flows work perfectly, it’s only that field that gives the issue…

In attachment I added a screenshot of the field that gives the issue (red circle)

thanks in advance!

Kr,


#2

Are you able to do manually?

If so, did you try:

  • Move Cursor

  • Send Control Key -> EraseEOF

  • Set field at Position


#3

Hey,

Thanks for your answer, I tried it but it doesn’t solve the problem.

I’m afraid the cause of the issue is this:

  • all fields within range 24*80 can be adjusted
  • but all fields outside this range (the field I’m trying to alter is on 07/081) aren’t found by UiPath, I just encountered the problem with another field outside this range…