"Terminal Error: Field not found"when executing "Set Field" on terminal session


I’m having an issue regarding “Set Field” activity on terminal session execution, more specifically:
I got “Field not found” error, but this issue occur infrequently.
I choose “Complete” at “Wait Type” property to waits for the terminal to be ready for input.

Is there another way to avoid this error?

1 Like

Alternative is that, you can use Move Cursor Activity to move to specific field using row and column value and then use Send Keys to enter your string.

And also have a logic to check if you are on correct page before updating the fields.

Hey @mei
May be the labled name you are passing is contain some space and all so better to use Set Filed at position
activity with Row and Column properties Because mostly i have faced terminals those will not change Rows and columns even you will maximize the screen but still depends on the vendor. with set filed at position will set your text at particular Row and column count position.


I got the same error as Mae when I use this Set Filed at position activity. Please advise. thanks


I also faced same error when I used set field activity…set field will not work for update values in mainframe screen. Hence go with send keys activity for update values.

Deepika Y