Terminal Control Keys already mapped


I’m working with a team that are trying to send a Page Up to a terminal application. As we understand it, the correct procedure would be two Send Control Key activities - one for ‘PA1’ and one for ‘F7’, which we’ve been told works.

However, the F7 key is already mapped in the system to a separate job, which gives UiPath trouble when trying to Page Up.

We using the UiPath internal provider for the terminal connection. Does anyone have experience with an issue like this, where you’ve needed to send a key to terminal that already has that key mapped to something else?



I’m confused by your issue.
Couldn’t you just use the correct key that mapped to the page up for your terminal profile? It might be good practice to use a standardized key mapping that is also used by the associates. In our situation, and to avoid problems with robots having wrong key mappings, we stored the profile file that stores the key maps in the project folder so it can be copied to the user’s profile before it opens the terminal session.

Then, just use the correct key for page up or whatever action is needed. So I am unsure other than that on how your problem can be solved.

Additionally, there are times when you might need to use the Send Hotkey instead of Send Control Key, but usually only when the emulator is not well supported for control keys. - this also would mean that you need to ensure you are attaching to the correct session window.

Hopefully, I answered this for you through all that confusion :laughing:



Hi ClaytonM,

Thanks for your response.

Apologies - my understanding of mainframe tech is really limited. The key that maps to page up in our profile is F7, but F7 also maps to a different job in the screen we’re looking at. Because of some restrictions, remapping the keys doesn’t seem to be possible.

We’ve tried Send Hotkey too, but even though we’re keeping the terminal connection open between activities and using an Attach Window with the correct selector, the window doesn’t accept any form of keyboard input, even manually entered.

P.S. Don’t worry, I’m confused by this too! Apologies I can’t provide any more details, I have no experience with mainframe applications.


That’s the confusing part. How can a screen have 1 key mapped to 2 different functions? Seems more like an issue with the emulator application, where the screen is using 1 key for 2 things.

Or maybe you mean the key is used on 2 different screens, which in that case, just make sure you are on the correct screen, so you can do page up/down with F7 with no problem.

Also, we use F8 and F7 for pagedown and pageup in our application, and have had no issues. But, we use TTWin emulator and our mainframe application is probably different. :man_shrugging: