Table Extraction Next Page not working

Hello, I’m trying to scrape data from the Alteryx website (more exactly this page: Alteryx Use Cases | Alteryx )

I’m using the Table Extraction activity in StudioX. However it looks like there is an issue with the bot identifying the next page selector. I’ve tried selecting different anchors, but no results after many tries and frustration. I’m suspecting it has something to do with the floating navigation pane.

The next page button is a simple right arrow as you can see on the above link.

I’d be really grateful for some help on this issue!

hey

first use an element exist activity and validate if this selector exist

<html app='chrome.exe' title='Alteryx Use Cases | Alteryx' />
<webctrl css-selector='body&gt;div&gt;div&gt;div&gt;main&gt;div&gt;div&gt;div&gt;ul&gt;li&gt;a&gt;svg&gt;g&gt;path' parentid='filters' tag='path' parentclass='next' idx='2' />

if exist then extract the data and then click that same selector, if not exist then the pages end

regards!

@atreides What is the error that you are getting

Hello @atreides ,

I tried the Table extraction using the same page and its working for me if I kept the zoom size to 30%. It means there is no issue with the Next button but if you are in 100% zoom the next buttom is at the very bottom and not identifiable. So my suggestion is instead of using the Next button in the Table extraction do it in a different approach

  1. Get the last page number using Get Text.
  2. Use a while loop ( i<9) 9 is the last page number for example.
    3)Table extratcion wothput next button
  3. use a scroll to bottom
  4. use click activity to click the next page number ( suppose if you want to click on page 2, inside the click activity you need to pass the value of “i” . if you check the selector there should be some attribute like idx.
  5. i=i+1

Hi Rahul! Thank you for the suggestion, but as far as I know StudioX does not have a while loop activity.

I have tried and the table extraction works for me at 25% zoom, but I don’t understand why the bot does not identify the element without seeing the entire webpage on the screen (zoomed out)… After all, the bot is looking for data in the html/css code isn’t it?